hdu1996汉诺塔VI

题目链接http://acm.hdu.edu.cn/showproblem.php?pid=1996

Problem Description
n个盘子的汉诺塔问题的最少移动次数是2^n-1,即在移动过程中会产生2^n个系列。由于
发生错移产生的系列就增加了,这种错误是放错了柱子,并不会把大盘放到小盘上,即各柱
子从下往上的大小仍保持如下关系 :
n=m+p+q 
a1>a2>...>am
b1>b2>...>bp
c1>c2>...>cq
计算所有会产生的系列总数.


Input
包含多组数据,首先输入T,表示有T组数据.每个数据一行,是盘子的数
目N<30.


Output
对于每组数据,输出移动过程中所有会产生的系列总数。


Sample Input
3
1
3 
29


Sample Output
3
27
68630377364883

看样例给的,29^3果然是68…….83, 好像是每个盘子都有三种选择,一交果然对。

#include <iostream>
#include <cmath>
using namespace std;

int main()
{int n;
 int t;
 cin>>t;
 while(t--)
 {
     cin>>n;
     cout<<(long long)pow(3.0,n)<<endl;
 }

    return 0;
}
    原文作者:B树
    原文地址: https://blog.csdn.net/aonaigayiximasi/article/details/47811583
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞