B - Pie

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
—One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
—One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655

好难啊,题目都读不懂。英语渣渣。
就是把N块饼分给F个人的问题。但是每个人分得的饼只能来自同一块饼,不能由多块饼拼凑。比如说:3块饼。体积分别是5 4 4 ,如果分给三个人,那么每个人最多分得的体积为4。

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
double Pi=acos(-1.0);
int F,N;
double v[10001];

bool test(double x)
{
    int num=0;
    for(int i=0;i<N;i++)
    {
         num+=int(v[i]/x);//int(v[i]/x) 表示第i-1块饼可以分给几个人。需要用强制类型转换 。 
    }
    if(num>=F)//如果所有的分得饼的人数大于总人数返回真 
        return true;
    else //否则条件不成立,返回假。 
        return false;
}
int main()
{

    int t;
    scanf("%d",&t);
    while(t--)
    {
        int f;
        int r;
        scanf("%d%d",&N,&f);
        F=f+1;//总人数 
        double V;//总体积 
        for(int i=0;i<N;i++)
        {
            scanf("%d",&r);
            v[i]=(r*r)*Pi;//每块饼的体积 
            V+=v[i];
        }
        double vp=V/F;//平均体积 
        double left=0;
        double right=vp;
        double mid;
        while((right-left)>0.0000001)//注意精度 
        {
            mid=(left+right)/2;
            if(test(mid))
                left=mid;
            else 
                right=mid;
         }
        printf("%.4lf\n",mid);

    }

    return 0;
}
    原文作者:B树
    原文地址: https://blog.csdn.net/l18339702017/article/details/76177931
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞