HDU 1576 - A/B(逆元)

A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9205    Accepted Submission(s): 7386

 

Problem Description

要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。

 

 

Input

数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。

 

 

Output

对应每组数据输出(A/B)%9973。

 

Sample Input

2

1000 53

87 123456789

Sample Output

7922

6060

Author

xhd

Source

HDU 2007-1 Programming Contest

题意:求 A *  inv(B)% Mod

板子题

#include <bits/stdc++.h>
using namespace std;
#define clr(a) memset(a,0,sizeof(a))
#define ling cout<<"-----------------"<<endl;

typedef long long ll;
const int maxn = 1e5+10;
const int MAXN = 1e6+10;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9+7;
const int N = 1010;

ll a,b;
ll fastpow(ll a,ll b,ll mod){
    ll ans = 1;
    a %= mod;
    while(b > 0){
        if(b & 1)
           ans = (ans * a) % mod;
        a = a * a % mod;
        b >>= 1;
    }
    return ans;
}
ll inv(ll a,ll p){
    return fastpow(a,p-2,p);
}
int main(){
	int t;
	scanf("%d",&t);
	int mod = 9973;
	while(t--){
		scanf("%lld%lld",&a,&b);
		int invb = inv(b,mod);
		printf("%lld\n",a * invb % mod );
	}
	return 0;
}

 

    原文作者:B树
    原文地址: https://blog.csdn.net/l18339702017/article/details/81870133
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞