Language: Default Shortest Prefixes
Description A prefix of a string is a substring starting at the beginning of the given string. The prefixes of “carbon” are: “c”, “ca”, “car”, “carb”, “carbo”, and “carbon”. Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, “carbohydrate” is commonly abbreviated by “carb”. In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. In the sample input below, “carbohydrate” can be abbreviated to “carboh”, but it cannot be abbreviated to “carbo” (or anything shorter) because there are other words in the list that begin with “carbo”. An exact match will override a prefix match. For example, the prefix “car” matches the given word “car” exactly. Therefore, it is understood without ambiguity that “car” is an abbreviation for “car” , not for “carriage” or any of the other words in the list that begins with “car”. Input The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters. Output The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word. Sample Input carbohydrate cart carburetor caramel caribou carbonic cartilage carbon carriage carton car carbonate Sample Output carbohydrate carboh cart cart carburetor carbu caramel cara caribou cari carbonic carboni cartilage carti carbon carbon carriage carr carton carto car car carbonate carbona Source |
题意:给定n个字符串,对于每个字符串,输出一个其最短的前缀字符串,使得该前缀不为其他字符串的前缀.
分析:裸的字典树,建立一颗字典树,trie的每一个点记录访问次数.
那么对于每个字符串,只需要找该字符串在trie中深度最小的访问=1的点.
注意考虑特殊情况,如字符串本身为其他字符串的前缀.
code:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
#define rep(i, l, r) for (int i = l; i <= r; i++)
#define REP(i, l, r) for (int i = l; i >= r; i--)
#define MAXN 50010
#define MAXM 50
struct trie{
int ch[MAXM], s, num, cnt;
}a[MAXN];
char str[MAXN][MAXM];
int n = 0, m;
inline int zm(char n) {return int(n)-96;}
inline void build(int I, int J, int k, char *str, int len) {
a[I].cnt++;
if (J == len) {
a[I].num = k;
return;
}
if (!a[I].ch[zm(str[J])]) a[a[I].ch[zm(str[J])] = ++m].s = zm(str[J]);
build(a[I].ch[zm(str[J])], J+1, k, str, len);
}
inline int getend(int I, int J, char *str, int len) {
if (J >= len) return J;
if (a[I].cnt > 1) getend(a[I].ch[zm(str[J])], J+1, str, len);
else return J;
}
int main() {
char ch[MAXM];
m = 1;
while (scanf("%s", ch) != EOF) {
strcpy(str[++n], ch);
build(1, 0, n, str[n], strlen(str[n]));
}
rep(i, 1, n) {
int end = getend(1, 0, str[i], strlen(str[i]));
printf("%s ", str[i]);
rep(j, 0, end-1) putchar(str[i][j]);
puts("");
}
return 0;
}