HDU4825 Xor Sum(Trie树 + 贪心)

Xor Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 1265    Accepted Submission(s): 527

Problem Description Zeus 和 Prometheus 做了一个游戏,Prometheus 给 Zeus 一个集合,集合中包含了N个正整数,随后 Prometheus 将向 Zeus 发起M次询问,每次询问中包含一个正整数 S ,之后 Zeus 需要在集合当中找出一个正整数 K ,使得 K 与 S 的异或结果最大。Prometheus 为了让 Zeus 看到人类的伟大,随即同意 Zeus 可以向人类求助。你能证明人类的智慧么?

 

Input 输入包含若干组测试数据,每组测试数据包含若干行。

输入的第一行是一个整数T(T < 10),表示共有T组数据。

每组数据的第一行输入两个正整数N,M(<1=N,M<=100000),接下来一行,包含N个正整数,代表 Zeus 的获得的集合,之后M行,每行一个正整数S,代表 Prometheus 询问的正整数。所有正整数均不超过2^32。  

Output 对于每组数据,首先需要输出单独一行”Case #?:”,其中问号处应填入当前的数据组数,组数从1开始计算。

对于每个询问,输出一个正整数K,使得K与S异或值最大。  

Sample Input

2 3 2 3 4 5 1 5 4 1 4 6 5 6 3  

Sample Output

Case #1: 4 3 Case #2: 4  

Source
2014年百度之星程序设计大赛 – 资格赛

题意:给出n个数,再给你m个数,问这m个数中分别能在这个n个数中找到能使这两个数的异或值最大的那个数。

暴力肯定爆时间,毫无疑问。

所以这道题我们要考虑建立字典树进行贪心来处理,很明显异或运算找最大值是要从高位开始,找有没有与目标数相应位置上不同的值,能找到就取,找不到就不取,这样从高位下来肯定是能达到最大值的,关于怎么从最高位开始找,我们就要借助字典树进行处理。

#include <cstdio>
#include <cstring>
using namespace std;

const int MAXN = 1E5 + 5;
int bits[50];

struct Trie {
    int data;
    Trie* child[2];
    Trie() {
        data = 0;
        memset(child, 0, sizeof(child));
    }
} *root;

void Insert(int num) {
    Trie* p = root;
    for (int i = 31; i >= 0; --i) {
        bool temp = bits[i] & num;
        if (p->child[temp] == NULL) {
            p->child[temp] = new Trie;
        }
        p = p->child[temp];
    }
    p->data = num;
}

int Find(int num) {
    Trie* p = root;
    for (int i = 31; i >= 0; --i) {
        bool temp = bits[i] & num;
        if (p->child[!temp]) {
            p = p->child[!temp];
        }
        else {
            p = p->child[temp];
        }
    }
    return p->data;
}

void Delete(Trie* p) {
    for (int i = 0; i <= 1; ++i) {
        if (p->child[i]) Delete(p->child[i]);
    }
    delete p;
}

int main() {
#ifndef ONLINE_JUDGE
    freopen("in.txt", "r", stdin);
#endif
    for (int i = 0; i < 32; ++i) {
        bits[i] = 1 << i;
    }
    int t, n, m, a;
    scanf("%d", &t);
    for (int ca = 1; ca <= t; ++ca) {
        root = new Trie;
        scanf("%d%d", &n, &m);
        while (n--) {
            scanf("%d", &a);
            Insert(a);
        }

        printf("Case #%d:\n", ca);
        while (m--) {
            scanf("%d", &a);
            printf("%d\n", Find(a));
        }
        Delete(root);
    }
    return 0;
}

    原文作者:Trie树
    原文地址: https://blog.csdn.net/night_13/article/details/51985052
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞