数据结构实验之查找一:二叉排序树【OJ--3373】

题目描述

  对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}

插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

输入

   输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以

空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。

  简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

输出

    对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出”Yes”,否则输出”No”。

示例输入

4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0

示例输出

Yes
No
No

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int cnt;
struct node
{
	int ch;
	node *l,*r;
};
void creat(node *&head,int x)                  //建二叉排序树
{
	if(x<head->ch)
	{
		if(head->l)
			creat(head->l,x);
		else
		{
			node *p;
			p=new node;
			p->ch=x;
			p->l=NULL;
			p->r=NULL;
			head->l=p;
			return ;
		}
	}
	else
	{
		if(head->r)
			creat(head->r,x);
		else
		{
			node *p;
			p=new node;
			p->ch=x;
			p->l=NULL;
			p->r=NULL;
			head->r=p;
			return ;
		}
	}
}
void coun(node *head1,node *head2)  //计算相等的节点个数
{
    if(!head1&&!head2)
        return ;
    if(head1&&head2)
    {
        if(head1->ch!=head2->ch)
            return ;
        else
            cnt++;
        coun(head1->l,head2->l);
        coun(head1->r,head2->r);
    }
    return ;
}

int main()
{
    int n,m;
    while(~scanf("%d",&n))
	{
		if(n==0)
			break;
		scanf("%d",&m);
		node *head;
		for(int i=0;i<n;i++)
		{
			int x;
			scanf("%d",&x);
		    if(i==0)
			{
				head=new node;
				head->ch=x;
				head->l=NULL;
				head->r=NULL;
				continue;
			}
			creat(head,x);
		}
		while(m--)
		{
			node *head1;
			cnt=0;
			for(int i=0;i<n;i++)
			{
				int x;
				scanf("%d",&x);
				if(i==0)
				{
					head1=new node;
					head1->ch=x;
					head1->l=NULL;
					head1->r=NULL;
					continue;
				}
				creat(head1,x);
			}
			coun(head,head1);
			if(cnt==n)
				printf("Yes\n");
			else
				printf("No\n");
		}
	}
    return 0;
}
    原文作者:二叉查找树
    原文地址: https://blog.csdn.net/zhang_di233/article/details/50299237
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞