DS查找—二叉树平衡因子
题目描述
二叉树用数组存储,将二叉树的结点数据依次自上而下,自左至右存储到数组中,一般二叉树与完全二叉树对比,比完全二叉树缺少的结点在数组中用0来表示。
计算二叉树每个结点的平衡因子,并按后序遍历的顺序输出结点的平衡因子。
–程序要求–
若使用C++只能include一个头文件iostream;若使用C语言只能include一个头文件stdio
程序中若include多过一个头文件,不看代码,作0分处理
不允许使用第三方对象或函数实现本题的要求
输入
测试次数t
每组测试数据一行,数组元素个数n,后跟n个字符,二叉树的数组存储。
输出
对每组测试数据,按后序遍历的顺序输出树中结点的平衡因子(测试数据没有空树)
样例输入
2
6 ABC00D
24 ABCD0EF0000H00000000000I
样例输出
B 0
D 0
C 1
A -1
D 0
B 1
I 0
H 1
E 2
F 0
C 2
A -2
Solution:
import java.util.*;
public class Main{
private static int n;
private static int MAXN = 1000;
public static void main(String args[]){
Scanner scanner = new Scanner(System.in);
// test times
int times = scanner.nextInt();
for (int k = 0; k <times ; k++) {
n = scanner.nextInt();
char[] array = new char[n+1];
int[] bf = new int[MAXN];//平衡因子数组,存储每个结点的平衡因子
String string = scanner.next();//由于Java无法读取单个字符,故先读取字符串,再分割
for (int i = 0; i <n ; i++) {
array[i] =string.charAt(i) ;
}
//get bf
//get each sub node's height
for (int i = 0; i <n ; i++) {//计算每个结点的平衡因子
//计算公式:左子树高度 - 右子树高度
bf[i] = get_height(array,2*i+1)-get_height(array,2*i+2);
}
//后序输出各非空结点的平衡因子
orderPrint(bf,array,0);
}
}
/**
* 求二叉树chars中,loc位置的结点的高度(从下往上计算,而非从根节点开始计算)
* @param chars
* @param loc
* @return
*/
public static int get_height(char[] chars,int loc){
if (loc>=n || chars[loc]=='0'){
return 0;
}else{
int left = get_height(chars,2*loc+1)+1;
int right = get_height(chars,2*loc+2)+1;
return left>right?left:right;//返回最大高度
}
}
public static void orderPrint(int[] bf,char[] chars,int i){
if (i<n){//后序输出
orderPrint(bf,chars,2*i+1);//先遍历左子树
orderPrint(bf,chars,2*i+2);//然后遍历右子树
if (chars[i]!='0')//最后访问(输出)根节点
System.out.println(chars[i]+" "+bf[i]);
}
}
}