进击的二叉查找树

进击的二叉查找树
Case Time Limit: 100 MS (Others) / 200 MS (Java) Case Memory Limit: 256 MB (Others) / 512 MB (Java)
Accepted: 254 Total Submission: 567
查看我的提交显示标签
Problem Description
给定1~N的两个排列,使用这两个排列分别构建两棵二叉查找树(也就是通过往一棵空树中依次插入序列元素的构建方式)。如果这两棵二叉查找树完全相同,那么输出YES;否则输出NO。之后,输出第一个排列对应的二叉查找树的后序序列、层序序列。
Input
每个输入文件中一组数据。

第一行1个正整数N(1<=N<=30),表示二叉查找树中的结点个数。

接下来两行,代表1~N的两个排列。
Output
如果两个排列代表的二叉查找树完全相同,那么输出一行YES,否则输出一行NO。

接下来两行分别输出第一个排列对应的二叉查找树的后序序列、层序序列,整数之间用空格隔开。

每行末尾不允许有多余的空格。
Sample Input
5

4 2 1 3 5

4 5 2 3 1
Sample Output
YES

1 3 2 5 4

4 2 5 1 3
Author
Shoutmon
Source
16浙大考研机试模拟赛

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <string>
#include <vector>
#include <queue>
#include <map>

using namespace std;

int n = 0;

typedef struct tnode {
    int data;
    struct tnode * lchild;
    struct tnode * rchild;
    tnode() { lchild = rchild = nullptr; }
}TNode, *PTNode;


void Insert(PTNode & root, int data) {
    if (!root) {
        root = new TNode;
        root->data = data;
    }

    if (root->data < data) Insert(root->rchild, data);
    else if (root->data > data) Insert(root->lchild, data);
}


PTNode CreateTree(int data[], int n) {
    PTNode root = nullptr;
    for (int i = 0; i < n; ++i) {
        Insert(root, data[i]);
    }
    return root;
}


void level(PTNode root) {
    if (!root)return;
    queue<PTNode>que; que.push(root);
    while (que.size()) {
        PTNode node = que.front(); que.pop();
        if (node->lchild) que.push(node->lchild);
        if (node->rchild) que.push(node->rchild);
        cout << node->data;
        if (que.size())cout << " ";
    }
}

int idx = 0;
void post(PTNode root) {
    if (!root)return;
    post(root->lchild);
    post(root->rchild);
    cout << root->data;
    if (++idx != n)cout << " ";
}


void juede(PTNode r1, PTNode r2, bool & same) {
    if (r1 == nullptr && r2 == nullptr) return;
    if (same) {
        if (!r1 && r2 || r1 && !r2 || r1->data != r2->data) {
            same = false;
            return;
        }
        juede(r1->lchild, r2->lchild, same);
        juede(r1->rchild, r2->rchild, same);
    }
}


int main() {
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif // _DEBUG
    std::ios::sync_with_stdio(false);

    int data[40]; PTNode r1, r2;
    cin >> n;
    for (int i = 0; i < n; ++i)cin >> data[i];
    r1 = CreateTree(data, n);
    for (int i = 0; i < n; ++i)cin >> data[i];
    r2 = CreateTree(data, n);

    bool same = true;
    juede(r1, r2, same);
    same ? (cout << "YES\n") : (cout << "NO\n");
    post(r1);
    cout << endl;
    level(r1);
    return 0;
}
    原文作者:二叉查找树
    原文地址: https://blog.csdn.net/fantasydreams/article/details/79522152
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞