建树的时候,有时候没有必要大费周章地去通过结点构造一棵二叉树,我们利用各结点之间的数学关系,通过数组就可以实现一棵二叉树,假设结点序列为a,那么其左子就是a*2,右子就是a*2+1
由于二叉树中序遍历的结果是一串有序序列,那么我们可以通过中序来得到一棵二叉树
void leveltra(int root) { //从根节点开始遍历
if (root > n) {
return;
}
leveltra(root * 2); //左节点递归
BST[root] = a[index++];
leveltra(root * 2 + 1); //右节点递归
}
//a表示有序序列,BST表示二叉搜索树
相关例题如下:
1064 Complete Binary Search Tree (30 分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node’s key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
- Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.
Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4
因为给出的是有序序列,所以我们可以以各个结点的位置序号为下标,来构造二叉树
如果按顺序输出结果,那么就是二叉树层序遍历的结果
实现代码如下:
#include <iostream>
#include <algorithm>
using namespace std;
int a[1010];
int levelTravese[1010];
int index = 1;
int n = 0;
void leveltra(int root) { //从根节点开始遍历
if (root > n) {
return;
}
leveltra(root * 2); //左节点
levelTravese[root] = a[index++];
leveltra(root * 2 + 1); //右节点
}
int main() {
cin >> n; //读入有多少个数
for (int i = 1; i <= n; ++i) {
cin >> a[i];
}
sort(a+1, a + n+1); //进行排序
leveltra(1);
for (int j = 1; j <= n; ++j) {
if (j == n) {
cout << levelTravese[j];
}
else {
cout << levelTravese[j] << " ";
}
}
system("PAUSE");
return 0;
}