pat(甲)1064--(搜索二叉树+满二叉树)

1064 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题意:给出n个数,求出它们构建的搜索二叉树的层序遍历。

心得:1、搜索二叉树的的中序遍历是序列的从小到大的排列。

2、满二叉树的性质:left=root*2;right=root*2+1,利用这个性质递归求解 (类似中序遍历)搜索二叉树的层序遍历。

 

#include<iostream>
#include<algorithm>
using namespace std;
int a[1010],b[1010];
int k,n;
void levelorder(int root)
{
	if(root>n) return ;
	int l=2*root,r=2*root+1;
	levelorder(l);
	b[root]=a[k++];
	levelorder(r);
}
int main(void)
{
	int i;
	scanf("%d",&n);
	for(i=0;i<n;i++) scanf("%d",&a[i]);
	sort(a,a+n);
	k=0;
	levelorder(1);
	for(i=1;i<n;i++) printf("%d ",b[i]);
	printf("%d\n",b[i]);
	return 0;
}

参考文章:https://blog.csdn.net/u014070398/article/details/78297136

    原文作者:满二叉树
    原文地址: https://blog.csdn.net/qq_41829060/article/details/82728720
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞