[ACM] sdut 2882 Full Binary Tree (满二叉树的公共祖先)

Full Binary Tree

Time Limit: 2000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

In computer science, a binary tree is a tree data structure in which each node has at most two children. Consider an infinite full binary tree (each node has two children except the leaf nodes) defined as follows. For a node labelled v its left child will be labelled 2 * v and its right child will be labelled 2 * v + 1. The root is labelled as 1.   You are given n queries of the form i, j. For each query, you have to print the length of the shortest path between node labelled i and node labelled j.  

输入

First line contains n(1 ≤ n ≤ 10^5), the number of queries. Each query consists of two space separated integers i and j(1 ≤ i, j ≤ 10^9) in one line.  

输出

For each query, print the required answer in one line.  

示例输入

5
1 2
2 3
4 3
1024 2048
3214567 9998877

示例输出

1
2
3
1
44

提示

 

来源

2014年山东省第五届ACM大学生程序设计竞赛

解题思路:

题意为一棵满二叉树,父节点编号为i,左孩子节点为i*2,右孩子节点编号为i*2+1,根节点编号为1,给定两个节点编号a,b,问a,b之间的最短路径是多少。

也就是求a,b的最近公共祖先。满二叉树每一层节点的编号x满足   2^p<=x<2^(p+1),所以先求出编号较小的数在哪一层,然后大的数跳到那一层,然后两个节点一起跳就可以了。

代码:

#include <iostream>
using namespace std;
int f[10000];//f[i]保存的是2的i次方
int len;

void pre()
{
    f[0]=1;
    for(int i=1;;i++)
    {
        f[i]=f[i-1]*2;
        if(f[i]>1e9)
        {
            len=i-1;
            break;
        }
    }
}

int a,b;
int t;
int main()
{
    pre();
    cin>>t;
    while(t--)
    {
        cin>>a>>b;
        if(a>b)
            swap(a,b);

        int step=0;
        int pos;//找到较小的数a在哪一层上,用pos保存
        for(int i=0;i<len;i++)
        {
            if(a>=f[i]&&a<f[i+1])
            {
                pos=i;
                break;
            }
        }
        while(1)//较大的数跳到与较小的数同一层上去
        {
            if(b>=f[pos]&&b<f[pos+1])
                break;
            b/=2;
            step++;
        }

        while(a!=b)//两个节点一起跳
        {
            a/=2;
            b/=2;
            step+=2;
        }
        cout<<step<<endl;
    }
    return 0;
}
    原文作者:满二叉树
    原文地址: https://blog.csdn.net/sr_19930829/article/details/41551377
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞