BST_满二叉树_2018_2_18

BST

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10462 Accepted: 6398

Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, …. In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as “What are the minimum and maximum numbers in the subtree whose root node is X?” Please try to find answers for there queries.

《BST_满二叉树_2018_2_18》

Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 2
31 – 1).

Output

There are N lines in total, the i-th of which contains the answer for the i-th query.

Sample Input

2
8
10

Sample Output

1 15
9 11

Source

POJ Monthly,Minkerui

#include<iostream>
#include<cstdio>
using namespace std;

int lowbit(int x){
	return x&-x;
} 

int main(){
	int n;
	scanf("%d",&n);
	int x;
	while(n--){
		scanf("%d",&x);
		printf("%d %d\n",x-lowbit(x)+1,x+lowbit(x)-1);
	}
}

    原文作者:满二叉树
    原文地址: https://blog.csdn.net/ujn20161222/article/details/79334831
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞