SDUT OJ 数据结构实验之二叉树三:统计叶子数

数据结构实验之二叉树三:统计叶子数

Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit 
Statistic 
Discuss

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并求二叉树的叶子结点个数。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

输出二叉树的叶子结点个数。

Sample Input

abc,,de,g,,f,,,

Sample Output

3

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct node
{
    char c;
    struct node *lt, *rt;
};

char s[100];
int i,k;

struct node *creat()
{
    struct node *root;
    if(s[i]==','){
        i++;
        root=NULL;
    }
    else{
        root=(struct node *)malloc(sizeof(struct node));
        root->c=s[i++];
        root->lt=creat();
        root->rt=creat();
    }
    return root;
}

void num(struct node *root)
{
    if(root){
        if(!root->lt&&!root->rt){
            k++;
        }
        num(root->lt);
        num(root->rt);
    }
}

int main()
{
    while(~scanf("%s",s))
    {
        i=0;k=0;
        struct node *root;
        root=creat();
        num(root);
        printf("%d\n",k);
    }
    return 0;
}

    原文作者:满二叉树
    原文地址: https://blog.csdn.net/winner647520/article/details/80514947
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞