判满二叉树(二叉树)

1.题目:


《判满二叉树(二叉树)》 Problem Description

设有一棵非空二叉树,其节点值为字符型并假设各值互不相等,采用二叉链表存储表示。设计一个算法,判断该二叉树是否为满二叉树。若是输出”yes”,不是则输出”no”。


《判满二叉树(二叉树)》 Input

第一行为一个整数n,表示以下有n组数据,每组数据占一行,为扩展二叉树的前序遍历序列。


《判满二叉树(二叉树)》 Output

若该二叉树是满二叉树输出”yes”,不是则输出”no”.


《判满二叉树(二叉树)》 Sample Input

2
AB#D##C##
ABD##E##C#F##


《判满二叉树(二叉树)》 Sample Output

no
no



2.参考代码:


#include <iostream>
using namespace std;

struct BiNode{
	char data;
	BiNode* lchild,* rchild;
};

class BiTree{
private:
	BiNode* root;
	BiNode* Creat();
	void Release(BiNode* root);
public:
	BiTree();
	~BiTree();
	BiNode* GetRoot(){
		return root;
	}
	bool judge(BiNode* root);
};

BiNode* BiTree::Creat(){
	BiNode* root=new BiNode;
	char ch;
	cin>>ch;
	if(ch=='#')
		root=NULL;
	else{
		root->data=ch;
		root->lchild=Creat();
		root->rchild=Creat();
	}
	return root;
}

void BiTree::Release(BiNode* root){
	if(root){
		Release(root->lchild);
		Release(root->rchild);
		delete root;
	}
}

BiTree::BiTree(){
	root=Creat();
}

BiTree::~BiTree(){
	Release(root);
}

bool BiTree::judge(BiNode* root){
	if(root->lchild==NULL && root->rchild==NULL)   ///必须先判断是否是叶子节点
		return true;
	if(root->lchild==NULL || root->rchild==NULL)   ////然后判断是否是非叶子节点
		return false;
	return (judge(root->lchild) && judge(root->rchild));
}

int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		BiTree bt;
		BiNode* root=bt.GetRoot();
		if(bt.judge(root))
			cout<<"yes\n";
		else
			cout<<"no\n";
	}
	return 0;
}



    原文作者:满二叉树
    原文地址: https://blog.csdn.net/x283930450/article/details/14087955
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞