算法提高 身份证排序

算法提高 身份证排序   时间限制:1.0s   内存限制:256.0MB     
问题描述   安全局搜索到了一批(n个)身份证号码,希望按出生日期对它们进行从大到小排序,如果有相同日期,则按身份证号码大小进行排序。身份证号码为18位的数字组成,出生日期为第7到第14位 输入格式   第一行一个整数n,表示有n个身份证号码

  余下的n行,每行一个身份证号码。 输出格式   按出生日期从大到小排序后的身份证号,每行一条 样例输入 5

466272307503271156

215856472207097978

234804580401078365

404475727700034980

710351408803093165 样例输出 404475727700034980

234804580401078365

215856472207097978

710351408803093165

466272307503271156 数据规模和约定   n<=100000

考查字符串排序,水题一道,险些超时。

#include <cstdio>
#include <algorithm>
#include <string>
#include <vector>
#include <iostream>

using namespace std;

vector<string> vec;

int cmp( string a, string b ) {
    string birthA = a.substr( 6, 8 );
    string birthB = b.substr( 6, 8 );

    if( birthA != birthB ) return birthA > birthB ? 1 : 0;

    return a > b ? 1 : 0;
}

int main() {
    //freopen( "123.txt", "r", stdin );
    int n;
    scanf( "%d", &n );
    string id;
    for( int i = 0; i < n; i++ ) {
        cin >> id;
        vec.push_back( id );
    }

    sort( vec.begin(), vec.end(), cmp );

    for( int i = 0; i < vec.size(); i++ ) {
        cout << vec[i] << endl;
    }
    return 0;
}
    原文作者:排序算法
    原文地址: https://blog.csdn.net/flx413/article/details/54094885
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞