biml – 为ScriptComponentProject设置.NET Framework版本

是否可以为ScriptComponentProject设置.NET Framework版本?

目前它默认为.NET 4,但我希望它是.NET 4.6.1

我查看了ScriptComponentProject(https://www.varigence.com/Documentation/Samples/Biml/Script+Component+Project)的文档页面,但没有任何运气.

最佳答案 啊,我找到了答案!您需要在脚本项目中设置Target Framework Version:

https://www.varigence.com/Documentation/Language/Element/AstComponentScriptProjectNode

我认为可用的值是这些:

不明
未指定的.NET Framework版本

NetFX20
.NET Framework 2.0

NetFX30
.NET Framework 3.0

NetFX35
.NET Framework 3.5

NetFX40
.NET Framework 4.0

NetFX45
.NET Framework 4.5

NetFX451
.NET Framework 4.5.1

NetFX452
.NET Framework 4.5.2

NetFX46
.NET Framework 4.6

NetFX461
.NET Framework 4.6.1

可以在这里找到:https://www.varigence.com/Documentation/Api/Enum/ScriptProjectTargetFrameworkVersion

    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞