HDU 4198 Quick out of the Harbour(BFS+优先队列)

Quick out of the Harbour

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 75    Accepted Submission(s): 47

Problem Description Captain Clearbeard decided to go to the harbour for a few days so his crew could inspect and repair the ship. Now, a few days later, the pirates are getting landsick(Pirates get landsick when they don’t get enough of the ships’ rocking motion. That’s why pirates often try to simulate that motion by drinking rum.). Before all of the pirates become too sick to row the boat out of the harbour, captain Clearbeard decided to leave the harbour as quickly as possible.

Unfortunately the harbour isn’t just a straight path to open sea. To protect the city from evil pirates, the entrance of the harbour is a kind of maze with drawbridges in it. Every bridge takes some time to open, so it could be faster to take a detour. Your task is to help captain Clearbeard and the fastest way out to open sea.

The pirates will row as fast as one minute per grid cell on the map. The ship can move only horizontally or vertically on the map. Making a 90 degree turn does not take any extra time.  

 

Input The first line of the input contains a single number: the number of test cases to follow. Each test case has the following format:

1. One line with three integers, h, w (3 <= h;w <= 500), and d (0 <= d <= 50), the height and width of the map and the delay for opening a bridge.

2.h lines with w characters: the description of the map. The map is described using the following characters:

—”S”, the starting position of the ship.

—”.”, water.

—”#”, land.

—”@”, a drawbridge.

Each harbour is completely surrounded with land, with exception of the single entrance.  

 

Output For every test case in the input, the output should contain one integer on a single line: the travelling time of the fastest route to open sea. There is always a route to open sea. Note that the open sea is not shown on the map, so you need to move outside of the map to reach open sea.  

 

Sample Input 2 6 5 7 ##### #S..# #@#.# #…# #@### #.### 4 5 3 ##### #S#.# #@..# ###@#  

 

Sample Output 16 11  

 

Source
BAPC 2011  

 

Recommend lcy       很简单的题目; 就是BFS+优先队列。。。 比赛的时候把sy打成sx了,,,WR到底啊。。。悲催啊,找了许久才发现问题。。。  

//广搜 + 优先队列,
#include<stdio.h>
#include<queue>
#include<iostream>
#include<string.h>
using namespace std;
const int MAXN=1010;
struct node
{
int x,y;
int time;
friend bool operator<(node a,node b)//time小的优先级高
{
return a.time>b.time;
}
};
priority_queue<node>que; //优先队列
char map[MAXN][MAXN];//记录map
int mark[MAXN][MAXN];

int h,w,d;
int sx,sy;
int bfs()
{
int k;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
node now,next;
while(!que.empty()) que.pop();
now.x=sx;now.y=sy;
now.time=1;

que.push(now);
while(!que.empty())
{
now=que.top();
que.pop();

mark[sx][sy]=1;
for(k=0;k<4;k++)
{
next.x=now.x+dir[k][0];
next.y=now.y+dir[k][1];
if(next.x<0||next.x>=h||next.y<0||next.y>=w) return now.time;


if(!mark[next.x][next.y] &&map[next.x][next.y]!='#')
{
if(map[next.x][next.y]=='@')
{
next.time = now.time+d+1;
}
else
next.time=now.time+1;
que.push(next);
mark[next.x][next.y]=1;
}
}
}
return -1;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d%d",&h,&w,&d);
//memset(mark,0,sizeof(mark));
for(int i=0;i<h;i++)
{
for(int j=0;j<w;j++)
{
scanf(" %c",&map[i][j]);

mark[i][j]=0;
if(map[i][j]=='S'){sx=i;sy=j;}

}
}


printf("%d\n",bfs());



}
return 0;
}
    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/04/03/2431261.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞