HDU 4034 Graph

Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 962    Accepted Submission(s): 510

Problem Description Everyone knows how to calculate the shortest path in a directed graph. In fact, the opposite problem is also easy. Given the length of shortest path between each pair of vertexes, can you find the original graph?  

 

Input The first line is the test case number T (T ≤ 100).

First line of each case is an integer N (1 ≤ N ≤ 100), the number of vertexes.

Following N lines each contains N integers. All these integers are less than 1000000.

The jth integer of ith line is the shortest path from vertex i to j.

The ith element of ith line is always 0. Other elements are all positive.  

 

Output For each case, you should output “Case k: ” first, where k indicates the case number and counts from one. Then one integer, the minimum possible edge number in original graph. Output “impossible” if such graph doesn’t exist.

 

 

Sample Input 3 3 0 1 1 1 0 1 1 1 0 3 0 1 3 4 0 2 7 3 0 3 0 1 4 1 0 2 4 2 0  

 

Sample Output Case 1: 6 Case 2: 4 Case 3: impossible  

 

Source
The 36th ACM/ICPC Asia Regional Chengdu Site —— Online Contest  

 

Recommend lcy        

#include<stdio.h>
const int MAXN=110;
int map[MAXN][MAXN];
int ans;//至少需要的边数
int n;//点数 
int Solve()
{
    for(int i=0;i<n;i++)
      for(int j=0;j<n;j++)
         for(int k=0;k<n;k++)
         {
             if(i!=j&&j!=k&&i!=k)
             {
                 if(map[i][j]==map[i][k]+map[k][j])
                 {
                     ans--;//这条边可以不需要的    
                     break;
                 }    
                 if(map[i][j]>map[i][k]+map[k][j]) 
                    return 0;//不可能的情况 
             }    
         }    
    return 1;
}     
int main()
{
    int T;
    scanf("%d",&T);

    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
          for(int j=0;j<n;j++)
            scanf("%d",&map[i][j]);
       
        ans=n*(n-1);//最多的边数
        if(Solve())
        {
            printf("%d\n",ans);
        }     
        else printf("impossible\n");
    }    
    return 0;
}    

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/04/13/2446386.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞