HDU 1039 Easier Done Than Said?(简单题)

Easier Done Than Said?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3965    Accepted Submission(s): 1999

Problem Description Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate “pronounceable” passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it’s your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for ‘ee’ or ‘oo’.

(For the purposes of this problem, the vowels are ‘a’, ‘e’, ‘i’, ‘o’, and ‘u’; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.  

 

Input The input consists of one or more potential passwords, one per line, followed by a line containing only the word ‘end’ that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.  

 

Output For each password, output whether or not it is acceptable, using the precise format shown in the example.  

 

Sample Input a tv ptoui bontres zoggax wiinq eep houctuh end  

 

Sample Output <a> is acceptable. <tv> is not acceptable. <ptoui> is not acceptable. <bontres> is not acceptable. <zoggax> is not acceptable. <wiinq> is not acceptable. <eep> is acceptable. <houctuh> is acceptable.  

 

Source
Mid-Central USA 2000         很简单的题目。。。 简单判断字符串就可以了。。。   现在发现杭电好多水题呢。。。。  

#include<stdio.h>
#include<string.h>
const int MAXN=200;
char str[MAXN];

bool isvowel(char c)
{
    if(c=='a'||c=='e'||c=='i'||c=='u'||c=='o') return true;
    else return false;
}    
bool judge1(int n)  //至少要有一个元音字母 
{
    for(int i=0;i<n;i++)
    {
        if(isvowel(str[i])) 
          return true;
    }    
    return false;
}    
bool judge2(int n)
{
    for(int i=2;i<n;i++)
    {
        if(isvowel(str[i-2])&&isvowel(str[i-1])&&isvowel(str[i])) return false;
        if(!isvowel(str[i-2])&&!isvowel(str[i-1])&&!isvowel(str[i])) return false;
    }    
    return true;
}    
bool judge3(int n)
{
    for(int i=1;i<n;i++)
    {
        if(str[i]==str[i-1]&&str[i]!='e'&&str[i]!='o') return false;
    }    
    return true;
}    
int main()
{
    int len;
    while(scanf("%s",&str)!=EOF)
    {
        if(strcmp(str,"end")==0) break;
        len=strlen(str);
        if(judge1(len)==false)
        {
            printf("<%s> is not acceptable.\n",str);
            continue;
        }    
        if(judge2(len)==false)
        {
            printf("<%s> is not acceptable.\n",str);
            continue;
        }    
        if(judge3(len)==false)
        {
            printf("<%s> is not acceptable.\n",str);
            continue;
        }    
        printf("<%s> is acceptable.\n",str);
    }    
    return 0;
}    

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/06/04/2533521.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞