HDU 1198 Farm Irrigation(并查集)

Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2559    Accepted Submission(s): 1145

Problem Description Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC

FJK

IHE

then the water pipes are distributed like

Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.  

 

Input There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of ‘A’ to ‘K’, denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.  

 

Output For each test case, output in one line the least number of wellsprings needed.  

 

Sample Input 2 2 DK HF 3 3 ADC FJK IHE -1 -1  

 

Sample Output 2 3  

 

Author ZHENG, Lu  

 

Source
Zhejiang University Local Contest 2005  

 

Recommend Ignatius.L      

#include<stdio.h>
const int MAXN=110;
char map[MAXN][MAXN];
int F[MAXN*MAXN];

int find(int x)
{
    if(F[x]==-1) return x;
    return F[x]=find(F[x]);
}    
void bing(int a,int b)
{
    int t1=find(a);
    int t2=find(b);
    if(t1!=t2) F[t1]=t2;
}    
int main()
{
    int m,n;
    while(scanf("%d%d",&m,&n))
    {
        if(m<0||n<0) break;
        for(int i=0;i<m;i++)
          scanf("%s",&map[i]);
        for(int i=0;i<m*n;i++)
          F[i]=-1;
        for(int i=0;i<m;i++)
          for(int j=0;j<n;j++)
          {
              if(i>0&&(map[i][j]=='A'||map[i][j]=='B'||map[i][j]=='E'||map[i][j]=='G'||map[i][j]=='H'||map[i][j]=='J'||map[i][j]=='K'))
                if(map[i-1][j]=='C'||map[i-1][j]=='D'||map[i-1][j]=='E'||map[i-1][j]=='H'||map[i-1][j]=='I'||map[i-1][j]=='J'||map[i-1][j]=='K')
                   bing(i*n+j,(i-1)*n+j);
              
              
                   
              if(j>0&&(map[i][j]=='A'||map[i][j]=='C'||map[i][j]=='F'||map[i][j]=='G'||map[i][j]=='H'||map[i][j]=='I'||map[i][j]=='K'))
                if(map[i][j-1]=='B'||map[i][j-1]=='D'||map[i][j-1]=='F'||map[i][j-1]=='G'||map[i][j-1]=='I'||map[i][j-1]=='J'||map[i][j-1]=='K')
                   bing(i*n+j,i*n+j-1);
          }    
       int res=0;
       for(int i=0;i<m*n;i++)
         if(F[i]==-1) res++;
       printf("%d\n",res);
    }    
    return 0;
}   

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/07/28/2612929.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞