HDU 1213 How Many Tables(并查集)

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6025    Accepted Submission(s): 2859

Problem Description Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.  

 

Input The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.  

 

Output For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.  

 

Sample Input 2 5 3 1 2 2 3 4 5 5 1 2 5  

 

Sample Output 2 4  

 

Author Ignatius.L  

 

Source
杭电ACM省赛集训队选拔赛之热身赛  

 

Recommend Eddy       简单并查集    

#include<stdio.h>
const int MAXN=1010;
int F[MAXN];
int find(int t)
{
    if(F[t]==-1) return t;
    return F[t]=find(F[t]);
}    
void bing(int a,int b)
{
    int t1=find(a);
    int t2=find(b);
    if(t1!=t2) F[t1]=t2;
}    
int main()
{
    int T;
    int n,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++) F[i]=-1;
        int a,b;
        while(m--)
        {
            scanf("%d%d",&a,&b);
            bing(a,b);
        }    
        int res=0;
        for(int i=1;i<=n;i++)
          if(F[i]==-1) res++;
        printf("%d\n",res);
    }    
    return 0;
}    

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/07/29/2613772.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞