HDU 1617 HDU 3630 Phone List(字典树)

Phone List

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16341 Accepted: 5228

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

Source

Nordic 2007           字典树。 写了三个代码。 第一个是动态分配,在POJ上会超时。 第二个是静态分配,POJ和HDU 都可以AC 第三个是排序判断,POJ上C++可以AC,G++超时  

/*******************************

Phone List 
HDU 1671 (AC)
POJ 3630  (未AC,超时了) 
********************************/

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace  std;
struct Node
{
    struct Node *br[10];
    int endflag;
};
Node *head;
bool flag;
void Tree_insert(char str[])//插入单词 
{
    Node *t,*s=head;
    int i,j;
    int len=strlen(str);
    for(i=0;i<len;i++)
    {
        int id=str[i]-'0';
        if(s->br[id]==NULL)
        {
            t=new Node;
            for(j=0;j<10;j++)
            {
                t->br[j]=NULL;
            }    
            t->endflag=0;
            s->br[id]=t;
        }    
        else
        {
            if(s->br[id]->endflag==1||str[i+1]=='\0')
            {
                flag=false;
                return;
            }    
        }    
        s=s->br[id];
    }    
    s->endflag=1;
}    

void Tree_Del(Node *p)
{
    for(int i=0;i<10;i++)
    {
        if(p->br[i]!=NULL)
          Tree_Del(p->br[i]);
    }    
    free(p);
}    

int main()
{
   //freopen("in.txt","r",stdin);
   // freopen("out.txt","w",stdout);
    int i;
    
    int T;
    int n;
    scanf("%d",&T);
    char str[30];
    while(T--)
    {
        scanf("%d",&n);
        flag=true;
        head=new Node;
        for(i=0;i<10;i++)
        {
           head->br[i]=NULL;
           head->endflag=0;
        }    
        for(i=0;i<n;i++)
        {
            //gets(str);
            scanf("%s",&str);
            if(flag)Tree_insert(str);
        }    
    
        if(flag) printf("YES\n");
        else printf("NO\n");
        Tree_Del(head);
    }    
    return 0;
}    

 

 

/************

Phone List  静态空间分配,可以节省时间 
POJ 3630 (G++和 C++都可以 AC 
HDU 1671  AC
**************/


#include<stdio.h>
#define MAX 10
typedef struct TrieNode
{
    int endflag;
    struct TrieNode *next[MAX];
}TrieNode;

TrieNode Memory[1000000];
int allocp=0;
bool flag;

void InitTrieRoot(TrieNode **pRoot)
{
    *pRoot=NULL;
}        

TrieNode *CreateTrieNode()
{
    int i;
    TrieNode *p;
    
    p=&Memory[allocp++];
    p->endflag=0;
    for(i=0;i<MAX;i++)
    {
        p->next[i]=NULL;
    }    
    return p;
}    

void InsertTrie(TrieNode **pRoot,char *s)
{
    int i,k;
    TrieNode *p;
    
    if(!(p=*pRoot))
      p=*pRoot=CreateTrieNode(); 
    i=0;
    while(s[i])
    {
        k=s[i++]-'0';
        if(p->next[k])
        {
            if(p->next[k]->endflag==1||s[i]=='\0')
            {
                flag=false;
                return;
            }    
        }    
        else p->next[k]=CreateTrieNode();
        p=p->next[k];
    }    
    p->endflag=1;
}    

int main()
{
    char str[50];
    TrieNode *Root=NULL;
    int T;
    scanf("%d",&T);
    int n;
    while(T--)
    {
        flag=true;
        allocp=0;
        scanf("%d",&n);
        InitTrieRoot(&Root);
        for(int i=0;i<n;i++)
        {
            //gets(str);//用这个会超时 
            scanf("%s",&str);
            if(flag) InsertTrie(&Root,str);
        }    
        if(flag) printf("YES\n");
        else printf("NO\n");
    }    
    
    
    return 0;
}    

 

//直接按照字典序排序,判断相邻的是不是前缀
//在POJ上用C++可以AC的,G++超时,郁闷
//HDU 1617 AC
//POJ 3630 

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<string>  //这个一定要 
#include<algorithm>
using namespace std;
const int MAXN=10010;


string str[MAXN];
bool judge(int n)
{
    int i,j;
    int len;
    for(i=0;i<n-1;i++)
    {
        len=str[i].size();
        for(j=0;j<len;j++)
          if(str[i][j]!=str[i+1][j]) break;
        if(j>=len) return false;
    }    
    return true;
}    
int main()
{
    int T;
    int n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++) cin>>str[i];
        sort(str,str+n);
        if(judge(n)) printf("YES\n");
        else printf("NO\n");
    }    
    return 0;
}    

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/08/05/2623705.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞