HDU 4349 Xiao Ming's Hope(数学题)

Xiao Ming’s Hope

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 433    Accepted Submission(s): 290

Problem Description Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn’t help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question “C
(n,0)+C
(n,1)+C
(n,2)+…+C
(n,n)=?”. Of course, Xiao Ming knew the answer, but he didn’t care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C
(1,0)=C
(1,1)=1, there are 2 odd numbers. When n is equal to 2, C
(2,0)=C
(2,2)=1, there are 2 odd numbers…… Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn’t want to let her down. Can you help him?  

 

Input Each line contains a integer n(1<=n<=10
8)  

 

Output A single line with the number of odd numbers of C
(n,0),C
(n,1),C
(n,2)…C
(n,n).  

 

Sample Input 1 2 11  

 

Sample Output 2 2 8  

 

Source
2012 Multi-University Training Contest 5  

 

Recommend zhuyuanchen520           求
C
(n,0)
,C
(n,1)
,C
(n,2)
…C
(n,n)
.当中有多少个奇数。  
就是统计N表示成二进制有多少个1,然后就是就是2^cnt。  

#include<stdio.h>
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int cnt=0;
        while(n)
        {
            if(n&1)cnt++;
            n>>=1;
        }
        printf("%d\n",1<<cnt);
    }
    return 0;
}

 

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/08/08/2628803.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞