HDU 1124 Factorial(简单数论)

Factorial

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1699    Accepted Submission(s): 1085

Problem Description The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically.

ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called “Travelling Salesman Problem” and it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4….N. The number is very high even for a relatively small N.

The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour of the factorial function.

For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1<N2, then Z(N1) <= Z(N2). It is because we can never “lose” any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently.  

 

Input There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.  

 

Output For every number N, output a single line containing the single non-negative integer Z(N).  

 

Sample Input 6 3 60 100 1024 23456 8735373  

 

Sample Output 0 14 24 253 5861 2183837  

 

Source
Central Europe 2000  

 

Recommend Eddy       就是求N!的末尾0的个数。 N!末尾的0一定是由2*5产生的。 而且2因子的个数一定比5因子的个数多。 所以只需要求N!的5因子的个数。 用到了一个数论知识: 若p是质数,p<=n,则n!是p的倍数,设p^x是p在n!内的最高幂,则 x=[n/p]+[n/p^2]+[n/p^3]+…………; 而且[n/(ab)]=[[n/a]/b]    

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define e exp(1.0)
#define PI acos(-1.0)
int main()
{
    int T;
    int n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        //int cnt2=0;
        int cnt5=0;
        int temp;
        /*
        temp=n/2;//2因子的个数一定比5大
        while(temp>0)
        {
            cnt2+=temp;
            temp/=2;
        }
        */
        temp=n/5;
        while(temp>0)
        {
            cnt5+=temp;
            temp/=5;
        }
        //if(cnt2>cnt5)printf("%d\n",cnt5);
        //else printf("%d\n",cnt2);
        printf("%d\n",cnt5);
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/08/10/2632589.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞