HDU 2147 kiki's game(组合博弈)

kiki’s game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/1000 K (Java/Others)
Total Submission(s): 3786    Accepted Submission(s): 2193

Problem Description Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can’t make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?  

 

Input Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

 

Output If kiki wins the game printf “Wonderful!”, else “What a pity!”.  

 

Sample Input 5 3 5 4 6 6 0 0  

 

Sample Output What a pity! Wonderful! Wonderful!  

 

Author 月野兔  

 

Source
HDU 2007-11 Programming Contest  

 

Recommend 威士忌      
这题很简单。。。如果直接去PN分析,程序交上去会MLE。。。
只有先PN分析,然后找出规律:发现n和m都是奇数的话是P点,就是必败。。
具体分析不说了。很简单  

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;

int main()
{
    //init();
    int n,m;
    while(scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        if(n%2==1&&m%2==1)printf("What a pity!\n");
        else printf("Wonderful!\n");
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/08/24/2653854.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞