POJ 1056 IMMEDIATE DECODABILITY(字典树,判断有没有一个是另一个的前缀)

IMMEDIATE DECODABILITY

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8895 Accepted: 4222

Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:

A:01 B:10 C:0010 D:0000

but this one is not:

A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable
 

Source

Pacific Northwest 1998         字典树基本的练习题。 判断立即码。 就是找有没有一个是另一个的前缀哦  

//POJ 1056 IMMEDIATE DECODABILITY
//就是看有没有字符串是另一个的前缀
//立即码(也叫异前置码)

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int MAX=2;
typedef struct Trie_Node
{
    bool isCode;
    struct Trie_Node *next[MAX];
}Trie;
bool flag;

void insert(Trie *root,char *str)
{
    Trie *p=root;
    int i=0;
    while(str[i]!='\0')
    {
        if(p->next[str[i]-'0']==NULL)
        {
            Trie *temp=new Trie;
            for(int j=0;j<MAX;j++)
              temp->next[j]=NULL;
            temp->isCode=false;
            p->next[str[i]-'0']=temp;
        }
        else
        {
            if(p->next[str[i]-'0']->isCode)
            {
                flag=false;
                return;
            }
        }
        p=p->next[str[i]-'0'];
        i++;
    }
    p->isCode=true;

}
void del(Trie *root)
{
    for(int i=0;i<MAX;i++)
      if(root->next[i]!=NULL)
        del(root->next[i]);
    free(root);
}
int main()
{
   // freopen("in.txt","r",stdin);
  //  freopen("out.txt","w",stdout);
    char str[20];
    int iCase=0;
    while(scanf("%s",&str)!=EOF)
    {
        iCase++;
        Trie *root=new Trie;
        for(int i=0;i<MAX;i++)
            root->next[i]=NULL;
        root->isCode=false;
        flag=true;
        insert(root,str);
        while(scanf("%s",&str))
        {
            if(strcmp(str,"9")==0)break;
            if(flag) insert(root,str);
        }
        if(flag)printf("Set %d is immediately decodable\n",iCase);
        else printf("Set %d is not immediately decodable\n",iCase);
        del(root);
    }
    return 0;
}

 

    原文作者:kuangbin
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/08/06/2624952.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞