HDU 1011 Starship Troopers(树形DP)

Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5726    Accepted Submission(s): 1529

Problem Description You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern’s structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.  

 

Input The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers — the amount of bugs inside and the possibility of containing a brain, respectively. The next N – 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1’s.  

 

Output For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.  

 

Sample Input 5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1  

 

Sample Output 50 7  

 

Author XU, Chuan  

 

Source
ZJCPC2004  

 

Recommend JGShining     做了树形DP专题,把这题以前做的又重新做了编。

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;

const int MAXN=110;
struct Node
{
    int to;
    int next;
}edge[MAXN*2];
int tol;
int head[MAXN];
int bug[MAXN];
int bra[MAXN];
int n,m;
int dp[MAXN][MAXN];
void init()
{
    memset(head,-1,sizeof(head));
    memset(dp,0,sizeof(dp));
    tol=0;
}

void add_edge(int a,int b)
{
    edge[tol].to=b;
    edge[tol].next=head[a];
    head[a]=tol++;
    edge[tol].to=a;
    edge[tol].next=head[b];
    head[b]=tol++;
}

void dfs(int u,int p)
{
    int temp=(bug[u]+19)/20;
    for(int i=temp;i<=m;i++)
       dp[u][i]=bra[u];
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].to;
        if(v==p)continue;
        dfs(v,u);
        for(int j=m;j>=temp;j--)//一定要倒序
          for(int k=1;k+j<=m;k++)
            dp[u][j+k]=max(dp[u][j+k],dp[u][j]+dp[v][k]);
    }
}
int main()
{
   // freopen("in.txt","r",stdin);
   // freopen("out.txt","w",stdout);
    int a,b;
    while(scanf("%d%d",&n,&m))
    {
        init();
        if(n==-1&&m==-1)break;
        for(int i=1;i<=n;i++)
          scanf("%d%d",&bug[i],&bra[i]);
        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            add_edge(a,b);
        }
        if(m==0)
        {
            printf("0\n");
            continue;
        }
        dfs(1,-1);
        printf("%d\n",dp[1][m]);

    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/08/28/2661053.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞