POJ 1195 Mobile phones(二维树状数组)

Mobile phones

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 11018 Accepted: 5044

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024

Cell value V at any time: 0 <= V <= 32767

Update amount: -32768 <= A <= 32767

No of instructions in input: 3 <= U <= 60002

Maximum number of phones in the whole table: M= 2^30

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source

IOI 2001         很裸的二维树状数组。 但是要注意题目给的是下标从0开始的,要加一变成从一开始,便于用树状数组做;

/*
POJ 1195 Mobile phones
二维树状数组
*/
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
const int MAXN=1030;
int c[MAXN][MAXN];
int n;
int lowbit(int x)
{
    return x&(-x);
}
void add(int x,int y,int val)
{
    for(int i=x;i<=n;i+=lowbit(i))
      for(int j=y;j<=n;j+=lowbit(j))
         c[i][j]+=val;
}
int sum(int x,int y)
{
    //if(x<=0||y<=0)return 0;
    int s=0;
    for(int i=x;i>0;i-=lowbit(i))
      for(int j=y;j>0;j-=lowbit(j))
         s+=c[i][j];
    return s;
}
int main()
{
    int X,Y,A;
    int L,B,R,T;
    int t;
    while(scanf("%d",&t)!=EOF)
    {
        scanf("%d",&n);
        memset(c,0,sizeof(0));
        while(scanf("%d",&t))
        {
            if(t==3)break;
            else if(t==1)
            {
                scanf("%d%d%d",&X,&Y,&A);
                add(X+1,Y+1,A);
            }
            else if(t==2)
            {
                scanf("%d%d%d%d",&L,&B,&R,&T);
                printf("%d\n",sum(R+1,T+1)-sum(R+1,B)-sum(L,T+1)+sum(L,B));
            }
        }
    }
    return 0;
}

 

    原文作者:kuangbin
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/08/09/2630139.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞