HDU 2594 Simpsons’ Hidden Talents(简单KMP)

 

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 939    Accepted Submission(s): 321

Problem Description Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.

Marge: Yeah, what is it?

Homer: Take me for example. I want to find out if I have a talent in politics, OK?

Marge: OK.

Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix

in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton

Marge: Why on earth choose the longest prefix that is a suffix???

Homer: Well, our talents are deeply hidden within ourselves, Marge.

Marge: So how close are you?

Homer: 0!

Marge: I’m not surprised.

Homer: But you know, you must have some real math talent hidden deep in you.

Marge: How come?

Homer: Riemann and Marjorie gives 3!!!

Marge: Who the heck is Riemann?

Homer: Never mind.

Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.  

 

Input Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.  

 

Output Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.

The lengths of s1 and s2 will be at most 50000.  

 

Sample Input clinton homer riemann marjorie  

 

Sample Output 0 rie 3  

 

Source
HDU 2010-05 Programming Contest  

 

Recommend lcy       求最长的相同前缀和后缀    

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;

const int MAXN=50010;
char str1[MAXN];
char str2[MAXN];

int next[MAXN];
int ex[MAXN];
void getNext(char *p)
{
    int j,k;
    j=0;
    k=-1;
    int len=strlen(p);
    next[0]=-1;
    while(j<len)
    {
        if(k==-1||p[j]==p[k])
        {
            j++;
            k++;
            next[j]=k;
        }
        else k=next[k];
    }
}

void get_ex(char *p,char *q)
{
    int len1=strlen(p);
    int len2=strlen(q);
    getNext(p);
    int i,k;
    ex[0]=0;
    i=0;
    k=0;
    while(i<len2)
    {
        if(k==-1||p[k]==q[i])
        {
            i++;
            k++;
            ex[i]=k;
        }
        else k=next[k];
    }
}
int main()
{
    while(scanf("%s%s",&str1,&str2)!=EOF)
    {
        get_ex(str1,str2);
        int n=strlen(str2);
        if(ex[n]==0)printf("0\n");
        else
        {
            for(int i=0;i<ex[n];i++)printf("%c",str1[i]);
            printf(" %d\n",ex[n]);
        }
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/08/30/2663674.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞