HDU 3635 Dragon Balls(并查集)

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1201    Accepted Submission(s): 484

Problem Description Five hundred years later, the number of dragon balls will increase unexpectedly, so it’s too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities’ dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.

Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.  

 

Input The first line of the input is a single positive integer T(0 < T <= 100).

For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).

Each of the following Q lines contains either a fact or a question as the follow format:

  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.

  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)  

 

Output For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.  

 

Sample Input 2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1  

 

Sample Output Case 1: 2 3 0 Case 2: 2 2 1 3 3 2  

 

Author possessor WC  

 

Source
2010 ACM-ICPC Multi-University Training Contest(19)——Host by HDU  

 

Recommend lcy        
水题一枚。。。
想到了并查集就是暴虐了。
主要是记录移动次数,其实每个根结点都是最多移动一次的,所以记录移动次数把自己的加上父亲结点的就是移动总数了

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN=10010;
int F[MAXN];
int num[MAXN];
int move[MAXN];

int n;

void init()
{
    for(int i=1;i<=n;i++)
    {
        F[i]=-1;
        num[i]=1;
        move[i]=0;
    }
}

int find(int x)
{
    if(F[x]==-1)return x;
    int t=F[x];
    F[x]=find(F[x]);
    move[x]+=move[t];
    return F[x];
}

void bing(int a,int b)
{
    int t1=find(a);
    int t2=find(b);
    if(t1!=t2)
    {
        F[t1]=t2;
        num[t2]+=num[t1];
        move[t1]=1;
    }
}

int main()
{
   // freopen("in.txt","r",stdin);
   // freopen("out.txt","w",stdout);
    int m;
    int T;
    char str[10];
    int a,b;
    int iCase=0;
    scanf("%d",&T);
    while(T--)
    {
        iCase++;
        scanf("%d%d",&n,&m);
        init();
        printf("Case %d:\n",iCase);
        while(m--)
        {
            scanf("%s",&str);
            if(str[0]=='T')
            {
                scanf("%d%d",&a,&b);
                bing(a,b);
            }
            else
            {
                scanf("%d",&a);
                int t=find(a);
                printf("%d %d %d\n",t,num[t],move[a]);
            }
        }
    }
    return 0;
}

 

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/08/30/2664419.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞