HDU 4122 Alice's mooncake shop(RMQ,或者单调队列)

Alice’s mooncake shop

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1183    Accepted Submission(s): 273

Problem Description The Mid-Autumn Festival, also known as the Moon Festival or Zhongqiu Festival is a popular harvest festival celebrated by Chinese people, dating back over 3,000 years to moon worship in China’s Shang Dynasty. The Zhongqiu Festival is held on the 15th day of the eighth month in the Chinese calendar, which is in September or early October in the Gregorian calendar. It is a date that parallels the autumnal equinox of the solar calendar, when the moon is at its fullest and roundest.

The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圆) also means something like “faultless” or “reuion”, so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.

Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients, the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours. She now asks you for help to work out a plan to minimize the cost to fulfill the orders.  

 

Input The input contains no more than 10 test cases.

For each test case:

The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens.

The next N lines describe all the orders. Each line is in the following format:

month date year H R

It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be “Jan”, “Feb”, “Mar”, “Apr”, “May”, “Jun”, “Jul”, “Aug”, “Sep”, “Oct”, “Nov” or “Dec”. H and R are all integers.

All the orders are sorted by the time in increasing order.

The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.

Finally, M lines follow. Among those M lines, the i
th line( i starts from 1) contains a integer indicating the cost to make a mooncake during the i
th hour . The cost is no more than 10000. Jan 1st 2000 0 o’clock belongs to the 1
st hour, Jan 1st 2000 1 o’clock belongs to the 2
nd hour, …… and so on.

(0<N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)

The input ends with N = 0 and M = 0.  

 

Output You should output one line for each test case: the minimum cost.  

 

Sample Input 1 10 Jan 1 2000 9 10 5 2 20 20 20 10 10 8 7 9 5 10 0 0  

 

Sample Output 70
Hint “Jan 1 2000 9 10” means in Jan 1st 2000 at 9 o’clock , there’s a consumer ordering 10 mooncakes. Maybe you should use 64-bit signed integers. The answer will fit into a 64-bit signed integer.  

 

Source
2011 Asia Fuzhou Regional Contest  

 

Recommend lcy      
去年福州赛区的题目。。永远的痛,当时竟然没有相当。。。唉。。。还是实力不够啊,今年再来吧
简单线段树或者RMQ或者单调队列找最小值。    

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;

int Day[12]={31,28,31,30,31,30,31,31,30,31,30,31};//每个月的天数

int getMonth(char *s)
{
    if(strcmp(s,"Jan")==0)  return 1;
    else if(strcmp(s,"Feb")==0)  return 2;
    else if(strcmp(s,"Mar")==0)  return 3;
    else if(strcmp(s,"Apr")==0)  return 4;
    else if(strcmp(s,"May")==0)  return 5;
    else if(strcmp(s,"Jun")==0)  return 6;
    else if(strcmp(s,"Jul")==0)  return 7;
    else if(strcmp(s,"Aug")==0)  return 8;
    else if(strcmp(s,"Sep")==0)  return 9;
    else if(strcmp(s,"Oct")==0)  return 10;
    else if(strcmp(s,"Nov")==0)  return 11;
    else if(strcmp(s,"Dec")==0)  return 12;
}
bool isleap(int year)
{
    if(year%400==0||(year%100!=0&&year%4==0)) return true;
    return false;
}

int getTime(char *s,int day,int year,int h)
{
    int res=0;
    for(int i=2000;i<year;i++)
    {
        if(isleap(i))res+=366*24;
        else res+=365*24;
    }
    int m=getMonth(s);
    for(int i = 1;i < m; i++)
    {
        res+=Day[i-1]*24;
        if(isleap(year)&&i==2)res+=24;
    }
    for(int i=1;i<day;i++)res+=24;
    res+=h+1;
    return res;
}

int times[3000];
int num[3000];
const int MAXN=100010;
int val[MAXN];
long long  tval[MAXN];
long long dp[MAXN][20];

void makeRMQIndex(int n,long long b[])//形成最小值下标的RMQ
{
    for(int i=0;i<n;i++)
        dp[i][0]=i;
    for(int j=1;(1<<j)<=n;j++)
      for(int i=0;i+(1<<j)-1<n;i++)
        dp[i][j]=b[dp[i][j-1]]<b[dp[i+(1<<(j-1))][j-1]]?dp[i][j-1]:dp[i+(1<<(j-1))][j-1];
}
int rmqIndex(int s,int v,long long b[])
{
    if(s<0)s=0;
    int k=(int)(log(v-s+1)/log(2.0));
    return b[dp[s][k]]<b[dp[v-(1<<k)+1][k]]?dp[s][k]:dp[v-(1<<k)+1][k];
}

int main()
{
   // freopen("in.txt","r",stdin);
   // freopen("out.txt","w",stdout);
    int N,M;
    char str[20];
    int d,y,h;
    int T,S;
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        if(N==0&&M==0)break;
        for(int i=0;i<N;i++)
        {
            scanf("%s%d%d%d%d",&str,&d,&y,&h,&num[i]);
            times[i]=getTime(str,d,y,h);
           // printf("%d\n",times[i]);
        }
        scanf("%d%d",&T,&S);
        for(int i=0;i<M;i++)
        {
            scanf("%d",&val[i]);
            tval[i]=val[i]+S*(M-1-i);
          //  printf("%I64d\n",tval[i]);
        }
        makeRMQIndex(M,tval);
      /*  for(int j=1;(1<<j)<=M;j++)
           for(int i=0;i+(1<<j)-1<M;i++)
             printf("i:%d  j:%d   %d\n",i,j,dp[i][j]);*/
        long long ans=0;
        for(int i=0;i<N;i++)
        {
            int temp=rmqIndex(times[i]-T,times[i]-1,tval);
          //  printf("%d   %d\n",times[i]-T,times[i]-1);
            int add=val[temp]+(times[i]-1-temp)*S;
            ans+=add*num[i];
           // printf("%d  %d\n",temp,add);
        }
        printf("%I64d\n",ans);

    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/09/02/2668039.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞