POJ 2253 Frogger(最短路的变形)

Frogger

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17842 Accepted: 5818

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.

Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source

Ulm Local 1997       最短路松弛的时候条件变一下就可以了。 DIjkstra算法

/*
POJ 2253
*/

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<iostream>
using namespace std;
const int MAXN=220;
const int INF=0x3f3f3f3f;



//***************************************************************
//Dijkstra-数组实现O(n^2)
//单源最短路径
//lowcost[]---从点beg到其他点的距离
//不记录路径
//结点编号从1开始的
//****************************************************************
#define INF 0x3f3f3f3f //这个无穷大不能太大,防止后面溢出
#define typec double
bool vis[MAXN];
void Dijkstra(typec cost[][MAXN],typec lowcost[MAXN],int n,int beg)
{
    typec minc;
    int i,j,w;
    memset(vis,false,sizeof(vis));
    vis[beg]=true;
    for(i=1;i<=n;i++)
       lowcost[i]=cost[beg][i];
    lowcost[beg]=0;
    for(i=1;i<n;i++)
    {
        minc=INF;
        for(j=1;j<=n;j++)
          if(!vis[j]&&lowcost[j]<minc)
          {
              minc=lowcost[j];
              w=j;
          }
        if(minc>=INF)break;
        vis[w]=true;
        for(j=1;j<=n;j++)
          if(!vis[j]&&max(lowcost[w],cost[w][j])<lowcost[j])
             lowcost[j]=max(lowcost[w],cost[w][j]);
    }
}
//**************************************************************
double dist[MAXN];
double map[MAXN][MAXN];

struct Node
{
    int x,y;
}node[MAXN];

double dis(Node a,Node b)
{
    return sqrt((double)(a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int n;
    int iCase=0;
    while(scanf("%d",&n),n)
    {
        iCase++;
        for(int i=1;i<=n;i++)
          scanf("%d%d",&node[i].x,&node[i].y);
        for(int i=1;i<=n;i++)
          for(int j=i;j<=n;j++)
          {
              if(i==j)map[i][j]=0;
              else map[i][j]=map[j][i]=dis(node[i],node[j]);
          }
        Dijkstra(map,dist,n,1);
        printf("Scenario #%d\nFrog Distance = ",iCase);
        printf("%.3f\n\n",(dist[2]));//POJ上G++只能用 %f
                                     //C++可以%lf
    }
    return 0;
}

 

    原文作者:kuangbin
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/08/18/2645637.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞