HDU 4287 Intelligent IME 第37届ACM/ICPC天津赛区网络赛1010题 (水题)

Intelligent IME

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 399    Accepted Submission(s): 207

Problem Description   We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:

  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o    

  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z

  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?  

 

Input   First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:

  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.  

 

Output   For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.  

 

Sample Input 1 3 5 46 64448 74 go in night might gn  

 

Sample Output 3 2 0  

 

Source
2012 ACM/ICPC Asia Regional Tianjin Online  

 

Recommend liuyiding      
水题真的好多。。。就算出水题也不能出这么水的吧。。。。
不解释了,很简单。

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int num[2000000];
int cc(char str[])
{
    int len=strlen(str);
    int ans=0;
    for(int i=0;i<len;i++)
    {
        ans*=10;
        if(str[i]=='a'||str[i]=='b'||str[i]=='c')ans+=2;
        else if(str[i]=='d'||str[i]=='e'||str[i]=='f')ans+=3;
        else if(str[i]=='g'||str[i]=='h'||str[i]=='i')ans+=4;
        else if(str[i]=='m'||str[i]=='n'||str[i]=='o')ans+=6;
        else if(str[i]>='p'&&str[i]<='s')ans+=7;
        else if(str[i]>='t'&&str[i]<='v')ans+=8;
        else if(str[i]>='w'&&str[i]<='z')ans+=9;
        else ans+=5;
    }
    return ans;
}
int a[10000];
char str[20];
int main()
{
    int T;
    int n,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(num,0,sizeof(num));
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        while(m--)
        {
            scanf("%s",&str);
            num[cc(str)]++;
        }
        for(int i=0;i<n;i++)
          printf("%d\n",num[a[i]]);
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/09/10/2678856.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞