POJ 1847 Tram(最短路)

Tram

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7180 Accepted: 2601

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer “-1”.

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0

Source

Croatia OI 2002 Regional – Juniors       很简单的最短路模版题。。 主要是建图。   把第一个相连的边设为0,其余的设为1.  

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;

const int MAXN=110;


//***************************************************************
//Dijkstra-数组实现O(n^2)
//单源最短路径
//lowcost[]---从点beg到其他点的距离
//不记录路径
//结点编号从1开始的
//****************************************************************
#define INF 0x3f3f3f3f //这个无穷大不能太大,防止后面溢出
#define typec int
bool vis[MAXN];
void Dijkstra(typec cost[][MAXN],typec lowcost[MAXN],int n,int beg)
{
    typec minc;
    int i,j,w;
    memset(vis,false,sizeof(vis));
    vis[beg]=true;
    for(i=1;i<=n;i++)
       lowcost[i]=cost[beg][i];
    lowcost[beg]=0;
    for(i=1;i<n;i++)
    {
        minc=INF;
        for(j=1;j<=n;j++)
          if(!vis[j]&&lowcost[j]<minc)
          {
              minc=lowcost[j];
              w=j;
          }
        if(minc>=INF)break;
        vis[w]=true;
        for(j=1;j<=n;j++)
          if(!vis[j]&&lowcost[w]+cost[w][j]<lowcost[j])
             lowcost[j]=lowcost[w]+cost[w][j];
    }
}
//**************************************************************
int cost[MAXN][MAXN];
int dist[MAXN];
int main()
{
    int n,A,B;
    int k;
    int t;
    while(scanf("%d%d%d",&n,&A,&B)!=EOF)
    {
        for(int i=1;i<=n;i++)
          for(int j=1;j<=n;j++)
          {
              if(i==j)cost[i][j]=0;
              else cost[i][j]=INF;
          }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&k);
            for(int j=0;j<k;j++)
            {
               scanf("%d",&t);
               if(j==0) cost[i][t]=0;
               else cost[i][t]=1;
            }
        }
        Dijkstra(cost,dist,n,A);
        if(dist[B]>=INF)printf("-1\n");
        else printf("%d\n",dist[B]);

    }
    return 0;
}

 

    原文作者:kuangbin
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/08/19/2646407.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞