HDU 4283 You Are the One 第37届ACM/ICPC 天津赛区网络赛 1006题 (DP)

You Are the One

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 402    Accepted Submission(s): 221

Problem Description   The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?  

 

Input   The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)

  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)  

 

Output   For each test case, output the least summary of unhappiness .  

 

Sample Input 2    5 1 2 3 4 5 5 5 4 3 2 2  

 

Sample Output Case #1: 20 Case #2: 24  

 

Source
2012 ACM/ICPC Asia Regional Tianjin Online  

 

Recommend liuyiding      
这么简单的DP,比赛时候竟然没有想出来。。。
唉。。。还是要多练习下DP啊  

/*
HDU 4283
DP

*/

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int MAXN=120;
const int INF=0x3f3f3f3f;
int num[MAXN];
int sum[MAXN];
int dp[MAXN][MAXN];//dp[i][j]表示从第i个数到第j个数形成的序列产生的最小值

int main()
{
    int T;
    int n;
    int iCase=0;
    scanf("%d",&T);
    while(T--)
    {
        iCase++;
        scanf("%d",&n);
        sum[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num[i]);
            sum[i]=sum[i-1]+num[i];
        }
        for(int i=1;i<=n;i++)
          for(int j=i;j<=n;j++)
            dp[i][j]=INF;
        for(int i=1;i<=n;i++)
            dp[i][i]=0;
        for(int len=1;len<n;len++)
           for(int i=1;i+len<=n;i++)
           {
               int j=i+len;
               dp[i][j]=min(dp[i][j],dp[i+1][j]+sum[j]-sum[i]);
               for(int k=i+1;k<=j;k++)
                 dp[i][j]=min(dp[i][j],dp[i+1][k]+num[i]*(k-i)+dp[k+1][j]+(sum[j]-sum[k])*(k-i+1));
           }
        printf("Case #%d: %d\n",iCase,dp[1][n]);
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/09/12/2681174.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞