HDU 3466 Proud Merchants (需要排序的01背包)

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1291    Accepted Submission(s): 532

Problem Description Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.

The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.

If he had M units of money, what’s the maximum value iSea could get?

 

 

Input There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.

Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

 

Output For each test case, output one integer, indicating maximum value iSea could get.

 

 

Sample Input 2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3  

 

Sample Output 5 11  

 

Author iSea @ WHU  

 

Source
2010 ACM-ICPC Multi-University Training Contest(3)——Host by WHU  

 

Recommend zhouzeyong      
按照q-p从小到大排序,然后01背包。
至于按照q-p从小到大排序比较难想到。q-p其实就是不更新的范围,不更新的范围从小到大递增时就不会影响后面的DP了。

/*
HDU 3466
需要排序的01背包

*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
const int MAXN=550;
struct Node
{
    int p,q,v;
}node[MAXN];
int dp[5500];
bool cmp(Node a,Node b)//按照 q-p 从小到大排序
{
    return a.q-a.p < b.q-b.p;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=0;i<n;i++)
          scanf("%d%d%d",&node[i].p,&node[i].q,&node[i].v);
        sort(node,node+n,cmp);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
          for(int j=m;j>=node[i].q;j--)
            dp[j]=max(dp[j],dp[j-node[i].p]+node[i].v);
        printf("%d\n",dp[m]);
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/09/14/2685826.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞