HDU 1059 Dividing(多重背包)

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9749    Accepted Submission(s): 2703

Problem Description Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.

Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.  

 

Input Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.

The last line of the input file will be “0 0 0 0 0 0”; do not process this line.  

 

Output For each colletcion, output “Collection #k:”, where k is the number of the test case, and then either “Can be divided.” or “Can’t be divided.”.

Output a blank line after each test case.  

 

Sample Input 1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0  

 

Sample Output Collection #1: Can’t be divided. Collection #2: Can be divided.  

 

Source
Mid-Central European Regional Contest 1999  

 

Recommend JGShining    
题意:价值分别为1,2,3,4,5,6的物品个数分别为a[1],a[2],a[3],a[4],a[5],a[6],问能不能分成两堆价值相等的。
解法:转化成多重背包

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;

int dp[120010];
int a[10];

int nValue;

//0-1背包,代价为cost,获得的价值为weight
void ZeroOnePack(int cost,int weight)
{
    for(int i=nValue;i>=cost;i--)
      dp[i]=max(dp[i],dp[i-cost]+weight);
}

//完全背包,代价为cost,获得的价值为weight
void CompletePack(int cost,int weight)
{
    for(int i=cost;i<=nValue;i++)
      dp[i]=max(dp[i],dp[i-cost]+weight);
}

//多重背包
void MultiplePack(int cost,int weight,int amount)
{
    if(cost*amount>=nValue) CompletePack(cost,weight);
    else
    {
        int k=1;
        while(k<amount)
        {
            ZeroOnePack(k*cost,k*weight);
            amount-=k;
            k<<=1;
        }
        ZeroOnePack(amount*cost,amount*weight);//这个不要忘记了,经常掉了
    }
}

int main()
{
    int iCase=0;
    while(1)
    {
        iCase++;
        int tol=0;
        for(int i=1;i<=6;i++)
        {
            scanf("%d",&a[i]);
            tol+=i*a[i];
        }
        if(tol==0)break;
        printf("Collection #%d:\n",iCase);
        if(tol%2!=0)
        {
            printf("Can't be divided.\n\n");
            continue;
        }
        else
        {
            nValue=tol/2;

        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=6;i++)
          MultiplePack(i,i,a[i]);
        if(dp[nValue]==nValue)printf("Can be divided.\n\n");
        else printf("Can't be divided.\n\n");
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/09/15/2686598.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞