HDU 2710 Max Factor (水题)

Max Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2238    Accepted Submission(s): 684

Problem Description To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.  

 

Input * Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line  

 

Output * Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.  

 

Sample Input 4 36 38 40 42  

 

Sample Output 38  

 

Source
USACO 2005 October Bronze  

 

Recommend teddy    
一大清早起来,刷了道水题。。。找了下感觉,试了下素数分解的模板,求下午网络赛给力啊。  
这个素数分解的模板用了很久了,真的是屡试不爽啊。。。哈哈  
此题注意对1的处理。把1的最大素因子当成1就可以AC了。

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;

const int MAXN=20000;
int prime[MAXN+1];
int getPrime()//得到小于等于MAXN的素数,prime[0]存放的是个数
{
    memset(prime,0,sizeof(prime));
    for(int i=2;i<=MAXN;i++)
    {
        if(!prime[i]) prime[++prime[0]]=i;
        for(int j=1;j<=prime[0]&&prime[j]<=MAXN/i;j++)
        {
            prime[prime[j]*i]=1;
            if(i%prime[j]==0) break;
        }
    }
    return prime[0];
}
long long factor[100][2];
int facCnt;
int getFactors(long long x)//把x进行素数分解
{
    facCnt=0;
    long long tmp=x;
    for(int i=1;prime[i]<=tmp/prime[i];i++)
    {
        factor[facCnt][1]=0;
        if(tmp%prime[i]==0)
        {
            factor[facCnt][0]=prime[i];
            while(tmp%prime[i]==0)
            {
                   factor[facCnt][1]++;
                   tmp/=prime[i];
            }
            facCnt++;
        }
    }
    if(tmp!=1)
    {
        factor[facCnt][0]=tmp;
        factor[facCnt++][1]=1;
    }
    return facCnt;
}




int main()
{
    int n;
    getPrime();
    int num;
    while(scanf("%d",&n)!=EOF)
    {
        int ans=0;
        int temp=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&num);
            if(num==1)//1的时候要单独处理一下
            {
                if(temp<1)
                {
                    temp=1;
                    ans=1;
                }
                continue;
            }
            getFactors(num);
            if(temp<factor[facCnt-1][0])
            {
                temp=factor[facCnt-1][0];
                ans=num;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/09/23/2698701.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞