HDU 4055 Number String(DP)

Number String

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 717    Accepted Submission(s): 311

Problem Description The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter ‘I’ (increasing) if the second element is greater than the first one, otherwise write down the letter ‘D’ (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is “DIIDID”.

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.  

 

Input Each test case consists of a string of 1 to 1000 characters long, containing only the letters ‘I’, ‘D’ or ‘?’, representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The ‘?’ in these strings can be either ‘I’ or ‘D’.  

 

Output For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.  

 

Sample Input II ID DI DD ?D ??  

 

Sample Output 1 2 2 1 3 6
Hint Permutation {1,2,3} has signature “II”. Permutations {1,3,2} and {2,3,1} have signature “ID”. Permutations {3,1,2} and {2,1,3} have signature “DI”. Permutation {3,2,1} has signature “DD”. “?D” can be either “ID” or “DD”. “??” gives all possible permutations of length 3.  

 

Author HONG, Qize  

 

Source
2011 Asia Dalian Regional Contest  

 

Recommend lcy    
很明显的DP题。
这是2011年大连现场赛的题目。
今天一看这题,迅速相出了DP方程,快速写完,1A。状态极好啊。
但是现场赛的时候不一定能想出来。上一年的我也肯定做不出来的。
希望今年给力。。。。。。。认真思考出题目。  
我是一个一个状态确定的。
假如第一个字符是’I’那么第一到第二要递增。其余后面的n-1个就相当于没有关系了。
比如第一个字符是1的话。那么把后面的又当成一个子问题。那么后面的开头的数可以是1,2,3“`n-1.
注意后面的n-1个数当成是1~n-1的排列符合后面字符。  
用dp[i][j]表示1~i的排列,以j开头的个数。  
那么就好讨论了。

/*
HDU 4055
DP
设dp[i][j]表示以j开头的,长度为i的排列的数目。
从字符串的后面到前面DP就得出答案了。
1A
G++ 1437ms
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
const int MAXN=1010;
const int MOD=1000000007;
char str[MAXN];
int dp[MAXN][MAXN];
int main()
{
   // freopen("in.txt","r",stdin);
   // freopen("out.txt","w",stdout);
    while(scanf("%s",&str)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        int n=strlen(str)+1;
        dp[1][1]=1;
        for(int i=2;i<=n;i++)
        {
            char ch=str[n-i];
            if(ch=='?')
            {
                for(int j=1;j<=i-1;j++)
                {
                    dp[i][1]+=dp[i-1][j];
                    dp[i][1]%=MOD;
                }
                for(int j=2;j<=i;j++)
                {
                    dp[i][j]=dp[i][j-1];
                    //dp[i][j]%=MOD;
                }

            }
            else if(ch=='I')
            {
                dp[i][i]=0;
                for(int j=i-1;j>=1;j--)
                {
                    dp[i][j]=dp[i][j+1]+dp[i-1][j];
                    dp[i][j]%=MOD;
                }

            }
            else if(ch=='D')
            {
                dp[i][1]=0;
                for(int j=2;j<=i;j++)
                {
                     dp[i][j]=dp[i][j-1]+dp[i-1][j-1];
                     dp[i][j]%=MOD;
                }
            }
        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            ans+=dp[n][i];
            ans%=MOD;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/10/04/2711330.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞