HDU 1078 FatMouse and Cheese (简单DP)

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2859    Accepted Submission(s): 1118

Problem Description FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse — after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.  

 

Input There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.

The input ends with a pair of -1’s.  

 

Output For each test case output in a line the single integer giving the number of blocks of cheese collected.  

 

Sample Input 3 1 1 2 5 10 11 6 12 12 7 -1 -1  

 

Sample Output 37  

 

Source
Zhejiang University Training Contest 2001     DP就可以了。 为了保证最优。按照从小到大的顺序DP。 或者用记忆化搜索也可以,这样好理解一些。

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
const int MAXN=110;
int a[MAXN][MAXN];
int dp[MAXN][MAXN];

struct Node
{
    int x,y;
    int val;
}node[MAXN*MAXN];
bool cmp(Node a,Node b)
{
    return a.val<b.val;
}

int main()
{
    int n,k;
    while(scanf("%d%d",&n,&k)==2)
    {
        if(n==-1&&k==-1)break;
        int cnt=0;
        for(int i=0;i<n;i++)
          for(int j=0;j<n;j++)
          {
              scanf("%d",&a[i][j]);
              if(i!=0||j!=0)
              {
                  node[cnt].x=i;
                  node[cnt].y=j;
                  node[cnt++].val=a[i][j];
              }
          }
        sort(node,node+cnt,cmp);
        memset(dp,-1,sizeof(dp));
        dp[0][0]=a[0][0];
        int ans=dp[0][0];
        for(int i=0;i<cnt;i++)
        {
            int x=node[i].x;
            int y=node[i].y;

            for(int xx=max(0,x-k);xx<=min(n-1,x+k);xx++)
            {
                if(a[xx][y]>=a[x][y])continue;
                if(dp[xx][y]==-1)continue;
                dp[x][y]=max(dp[x][y],dp[xx][y]+a[x][y]);
            }
            for(int yy=max(0,y-k);yy<=min(n-1,y+k);yy++)
            {
                if(a[x][yy]>=a[x][y])continue;
                if(dp[x][yy]==-1)continue;
                dp[x][y]=max(dp[x][y],dp[x][yy]+a[x][y]);
            }
            ans=max(ans,dp[x][y]);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/10/20/2731994.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞