HDU 1052 Tian Ji -- The Horse Racing (贪心)

Tian Ji — The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11572    Accepted Submission(s): 3239

Problem Description Here is a famous story in Chinese history.

“That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.”

“Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.”

“Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian’s. As a result, each time the king takes six hundred silver dollars from Tian.”

“Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.”

“It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king’s regular, and his super beat the king’s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?”

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian’s horses on one side, and the king’s horses on the other. Whenever one of Tian’s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching…

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses — a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.  

 

Input The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.  

 

Output For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.  

 

Sample Input 3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0  

 

Sample Output 200 0 0  

 

Source
2004 Asia Regional Shanghai  

 

Recommend JGShining     贪心策略. 很容易被题目意思误导过去用最大权值匹配。 一、如果a的最慢速度大于b的最慢,则直接a的最慢与b的最慢比赛,赢一场;

二、如果a的最慢速度小于b的最慢,则用a的最慢浪费b的最快,输一场;

三、如果a的最慢速度等于b的最慢,则:

1.如果a的最快速度大于b的最快,则直接a的最快与b的最快进行比赛,赢一场;

2.如果b的最快速度小于b的最快,则用a的最慢浪费b的最快,输一场;

3.如果a的最快速度等于b的最快,即a与b的最慢与最快分别相等,则:

a.如果a的最慢速度小于b的最快,则用a的最慢浪费b的最快,输一场;

b.如果a的最慢速度等于b的最快,即a的最慢、a的最快、b的最慢、b的最快相等,

说明剩余未比赛的马速度全部相等,直接结束比赛。   贪心策略也容易理解。但是证明比较麻烦,不去理解了。

/*
HDU 1052
一、如果a的最慢速度大于b的最慢,则直接a的最慢与b的最慢比赛,赢一场;
二、如果a的最慢速度小于b的最慢,则用a的最慢浪费b的最快,输一场;
三、如果a的最慢速度等于b的最慢,则:
1.如果a的最快速度大于b的最快,则直接a的最快与b的最快进行比赛,赢一场;
2.如果b的最快速度小于b的最快,则用a的最慢浪费b的最快,输一场;
3.如果a的最快速度等于b的最快,即a与b的最慢与最快分别相等,则:
a.如果a的最慢速度小于b的最快,则用a的最慢浪费b的最快,输一场;
b.如果a的最慢速度等于b的最快,即a的最慢、a的最快、b的最慢、b的最快相等,
说明剩余未比赛的马速度全部相等,直接结束比赛。

*/
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int MAXN=1010;
int a[MAXN],b[MAXN];
int main()
{
    int n;
    while(scanf("%d",&n)==1&&n)
    {
        for(int i=0;i<n;i++)scanf("%d",&a[i]);
        for(int i=0;i<n;i++)scanf("%d",&b[i]);
        sort(a,a+n);
        sort(b,b+n);
        int al=0,ah=n-1;
        int bl=0,bh=n-1;
        int ans=0;
        while(al<=ah&&bl<=bh)
        {
            if(a[al]>b[bl])
            {
                ans+=200;
                al++;bl++;
            }
            else if(a[al]<b[bl])
            {
                ans-=200;
                al++;bh--;
            }
            else
            {
                if(a[ah]>b[bh])
                {
                    ans+=200;
                    ah--;bh--;
                }
                else if(a[ah]<b[bh])
                {
                    ans-=200;
                    al++;bh--;
                }
                else
                {
                    if(a[al]<b[bh])
                    {
                        ans-=200;
                        al++;bh--;
                    }
                    else if(a[al]==b[bh])//所有的都一样了
                    {
                        break;
                    }
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/10/23/2735800.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞