POJ 3207 Ikki's Story IV - Panda's Trick(2-SAT)

Ikki’s Story IV – Panda’s Trick

Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 6065 Accepted: 2234

Description

liympanda, one of Ikki’s friend, likes playing games with Ikki. Today after minesweeping with Ikki and winning so many times, he is tired of such easy games and wants to play another game with Ikki.

liympanda has a magic circle and he puts it on a plane, there are n points on its boundary in circular border: 0, 1, 2, …, n − 1. Evil panda claims that he is connecting m pairs of points. To connect two points, liympanda either places the link entirely inside the circle or entirely outside the circle. Now liympanda tells Ikki no two links touch inside/outside the circle, except on the boundary. He wants Ikki to figure out whether this is possible…

Despaired at the minesweeping game just played, Ikki is totally at a loss, so he decides to write a program to help him.

Input

The input contains exactly one test case.

In the test case there will be a line consisting of of two integers: n and m (n ≤ 1,000, m ≤ 500). The following m lines each contain two integers ai and bi, which denote the endpoints of the ith wire. Every point will have at most one link.

Output

Output a line, either “panda is telling the truth...” or “the evil panda is lying again”.

Sample Input

4 2
0 1
3 2

Sample Output

panda is telling the truth...

Source

POJ Monthly–2007.03.04, Ikki     又是一题2-SAT的可行性判别的题目。 建图后模板就可以了。  

/*
POJ 3207
题意:平面上,一个圆,圆的边上按顺时针放着n个点。现在要连m条边,
比如a,b,那么a到b可以从圆的内部连接,也可以从圆的外部连接。
给你的信息中,每个点最多只会连接的一条边。问能不能连接这m条边,
使这些边都不相交。

思路:对于每条Link,要么在圆外,要么在圆内,且不可同时满足,
只能两者取一,判断这M条Link是否合法,也就是M条Link不冲突,
这就是典型的2-sat问题了。 将每条Link i 看做一个点,如果Link在圆内,
则选做i ,如果在圆外, 则选做i'。对于两条线(i,j) ,如果i,j不能同时
在圆内,也就可以推出两者不能同时在圆外,这个证明很容易,读者可
以自行证明。i, j不能同时在圆内,则有边(i, j') 、(j ,i')、(i',j)、(j' ,i)
(这是由2-sat的构图方式决定的,具体可以看《由对称性解2-SAT问题》
 这篇论文)。建图完了之后,本题就是判断2-sat问题是否有解,
 先求原图的强连通分量,并缩点,(这里我们称:(i,i')属于同一组),
 判断是否存在(i,i')属于同一组,若存在,则不可能,若不存在则可能。

C++ 204MS  2248K

*/
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
#include<math.h>
#include<queue>
#include<vector>
using namespace std;
const int MAXN=1010;


bool visit[MAXN];
queue<int>q1,q2;
//vector建图方法很妙
vector<vector<int> >adj; //原图    //中间一定要加空格把两个'>'隔开
vector<vector<int> >radj;//逆图
vector<vector<int> >dag;//缩点后的逆向DAG图
int n,cnt;

int id[MAXN],order[MAXN],ind[MAXN];//强连通分量,访问顺序,入度

void dfs(int u)
{
    visit[u]=true;
    int i,len=adj[u].size();
    for(i=0;i<len;i++)
      if(!visit[adj[u][i]])
        dfs(adj[u][i]);
    order[cnt++]=u;
}
void rdfs(int u)
{
    visit[u]=true;
    id[u]=cnt;
    int i,len=radj[u].size();
    for(i=0;i<len;i++)
      if(!visit[radj[u][i]])
        rdfs(radj[u][i]);
}
void korasaju()
{
    int i;
    memset(visit,false,sizeof(visit));
    for(cnt=0,i=0;i<2*n;i++)
      if(!visit[i])
        dfs(i);
    memset(id,0,sizeof(id));
    memset(visit,false,sizeof(visit));
    for(cnt=0,i=2*n-1;i>=0;i--)
      if(!visit[order[i]])
      {
          cnt++;//这个一定要放前面来
          rdfs(order[i]);
      }
}
bool solvable()
{
    for(int i=0;i<n;i++)
      if(id[2*i]==id[2*i+1])
        return false;
   return true;
}

struct Node
{
    int s,t;
}node[MAXN];
int main()
{
    int N;
    int x,y;
    while(scanf("%d%d",&N,&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            if(x>y)swap(x,y);
            node[i].s=x;
            node[i].t=y;
        }
        adj.assign(2*n,vector<int>());
        radj.assign(2*n,vector<int>());
        for(int i=0;i<n;i++)
          for(int j=i+1;j<n;j++)
          {
              if((node[i].s<node[j].s&&node[j].s<node[i].t&&node[i].t<node[j].t)||(node[j].s<node[i].s&&node[i].s<node[j].t&&node[j].t<node[i].t))
              {
                  adj[2*i].push_back(2*j+1);
                  adj[2*j+1].push_back(2*i);
                  adj[2*i+1].push_back(2*j);
                  adj[2*j].push_back(2*i+1);
                  radj[2*j+1].push_back(2*i);
                  radj[2*i].push_back(2*j+1);
                  radj[2*j].push_back(2*i+1);
                  radj[2*i+1].push_back(2*j);
              }
          }
        korasaju();
        if(solvable())printf("panda is telling the truth...\n");
        else printf("the evil panda is lying again\n");
    }
    return 0;
}

 

    原文作者:kuangbin
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/10/06/2712782.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞