HDU 4432 Sum of divisors 第37届ACM/ICPC天津现场赛B题 (简单题)

Sum of divisors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 82    Accepted Submission(s): 35

Problem Description mmm is learning division, she’s so proud of herself that she can figure out the sum of all the divisors of numbers no larger than 100 within one day!

But her teacher said “What if I ask you to give not only the sum but the square-sums of all the divisors of numbers within hexadecimal number 100?” mmm get stuck and she’s asking for your help.

Attention, because mmm has misunderstood teacher’s words, you have to solve a problem that is a little bit different.

Here’s the problem, given n, you are to calculate the square sums of the digits of all the divisors of n, under the base m.  

 

Input Multiple test cases, each test cases is one line with two integers.

n and m.(n, m would be given in 10-based)

1≤n≤10
9

2≤m≤16

There are less then 10 test cases.  

 

Output Output the answer base m.  

 

Sample Input 10 2 30 5  

 

Sample Output 110 112
Hint Use A, B, C…… for 10, 11, 12…… Test case 1: divisors are 1, 2, 5, 10 which means 1, 10, 101, 1010 under base 2, the square sum of digits is 1^2+ (1^2 + 0^2) + (1^2 + 0^2 + 1^2) + …. = 6 = 110 under base 2.  

 

Source
2012 Asia Tianjin Regional Contest  

 

Recommend zhoujiaqi2010     这题是比较简单的了。 就是枚举找到约数,然后进制转换就可以了。 注意枚举约数的时候是1-sqrt(n)去枚举,一次找到两个约数。不要1-n枚举,会超时的。

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;

int bit[100];
int cnt;

void change(int n,int base)
{
    cnt=0;
    while(n)
    {
        bit[cnt++]=n%base;
        n/=base;
    }
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int sum=0;
        int t=(int)sqrt(n*1.0);
        for(int i=1;i<=t;i++)
        {
            if(n%i==0)
            {
                int tmp=i;
                while(tmp)
                {
                    sum+=((tmp%m)*(tmp%m));
                    tmp/=m;
                }
                tmp=n/i;
                if(tmp==i)continue;
                while(tmp)
                {
                    sum+=((tmp%m)*(tmp%m));
                    tmp/=m;
                }
            }
        }
        change(sum,m);
        for(int i=cnt-1;i>=0;i--)
        {
            if(bit[i]>9)printf("%c",bit[i]-10+'A');
            else printf("%d",bit[i]);
        }
        printf("\n");
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2012/10/26/2741144.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞