POJ 3259 Wormholes(最短路,判断有没有负环回路)

Wormholes

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24249 Accepted: 8652

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, 
F
F farm descriptions follow. 

Line 1 of each farm: Three space-separated integers respectively: 
N
M, and 
W 

Lines 2..
M+1 of each farm: Three space-separated numbers (
S
E
T) that describe, respectively: a bidirectional path between 
S and 
E that requires 
T seconds to traverse. Two fields might be connected by more than one path. 

Lines 
M+2..
M+
W+1 of each farm: Three space-separated numbers (
S
E
T) that describe, respectively: A one way path from 
S to 
E that also moves the traveler back 
T seconds.

Output

Lines 1..
F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

USACO 2006 December Gold         这题就是判断存不存在负环回路。 前M条是双向边,后面的W是单向的负边。   为了防止出现不连通, 增加一个结点作为起点。 起点到所有点的长度为0   bellman_ford算法:

/*
 * POJ 3259
 * 判断图中是否存在负环回路。
 * 为了防止图不连通的情况,增加一个点作为起点,这个点和其余的点都相连。
 */

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;
/*
 * 单源最短路bellman_ford算法,复杂度O(VE)
 * 可以处理负边权图。
 * 可以判断是否存在负环回路。返回true,当且仅当图中不包含从源点可达的负权回路
 * vector<Edge>E;先E.clear()初始化,然后加入所有边
 * 点的编号从1开始(从0开始简单修改就可以了)
 */
const int INF=0x3f3f3f3f;
const int MAXN=550;
int dist[MAXN];
struct Edge
{
    int u,v;
    int cost;
    Edge(int _u=0,int _v=0,int _cost=0):u(_u),v(_v),cost(_cost){}
};
vector<Edge>E;
bool bellman_ford(int start,int n)//点的编号从1开始
{
    for(int i=1;i<=n;i++)dist[i]=INF;
    dist[start]=0;
    for(int i=1;i<n;i++)//最多做n-1次
    {
        bool flag=false;
        for(int j=0;j<E.size();j++)
        {
            int u=E[j].u;
            int v=E[j].v;
            int cost=E[j].cost;
            if(dist[v]>dist[u]+cost)
            {
                dist[v]=dist[u]+cost;
                flag=true;
            }
        }
        if(!flag)return true;//没有负环回路
    }
    for(int j=0;j<E.size();j++)
        if(dist[E[j].v]>dist[E[j].u]+E[j].cost)
            return false;//有负环回路
    return true;//没有负环回路
}

int main()
{
//    freopen("in.txt","r",stdin);
//    freopen("out.txt","w",stdout);
    int T;
    int N,M,W;
    int a,b,c;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&N,&M,&W);
        E.clear();
        while(M--)
        {
            scanf("%d%d%d",&a,&b,&c);
            E.push_back(Edge(a,b,c));
            E.push_back(Edge(b,a,c));
        }
        while(W--)
        {
            scanf("%d%d%d",&a,&b,&c);
            E.push_back(Edge(a,b,-c));
        }
        for(int i=1;i<=N;i++)
            E.push_back(Edge(N+1,i,0));
        if(!bellman_ford(N+1,N+1))printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

 

 

 

SPFA算法:

//============================================================================
// Name        : POJ.cpp
// Author      : 
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;
/*
 * 单源最短路SPFA
 * 时间复杂度 0(kE)
 * 这个是队列实现,有时候改成栈实现会更加快,很容易修改
 * 这个复杂度是不定的
 */
const int MAXN=1010;
const int INF=0x3f3f3f3f;
struct Edge
{
    int v;
    int cost;
    Edge(int _v=0,int _cost=0):v(_v),cost(_cost){}
};
vector<Edge>E[MAXN];
void addedge(int u,int v,int w)
{
    E[u].push_back(Edge(v,w));
}
bool vis[MAXN];
int cnt[MAXN];
int dist[MAXN];
bool SPFA(int start,int n)
{
    memset(vis,false,sizeof(vis));
    for(int i=1;i<=n;i++)dist[i]=INF;
    dist[start]=0;
    vis[start]=true;
    queue<int>que;
    while(!que.empty())que.pop();
    que.push(start);
    memset(cnt,0,sizeof(cnt));
    cnt[start]=1;
    while(!que.empty())
    {
        int u=que.front();
        que.pop();
        vis[u]=false;
        for(int i=0;i<E[u].size();i++)
        {
            int v=E[u][i].v;
            if(dist[v]>dist[u]+E[u][i].cost)
            {
                dist[v]=dist[u]+E[u][i].cost;
                if(!vis[v])
                {
                    vis[v]=true;
                    que.push(v);
                    if(++cnt[v]>n)return false;
                    //有负环回路
                }
            }
        }
    }
    return true;
}
int main()
{
//    freopen("in.txt","r",stdin);
//    freopen("out.txt","w",stdout);
    int T;
    int N,M,W;
    int a,b,c;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&N,&M,&W);
        for(int i=1;i<=N+1;i++)E[i].clear();
        while(M--)
        {
            scanf("%d%d%d",&a,&b,&c);
            addedge(a,b,c);
            addedge(b,a,c);
        }
        while(W--)
        {
            scanf("%d%d%d",&a,&b,&c);
            addedge(a,b,-c);
        }
        for(int i=1;i<=N;i++)
            addedge(N+1,i,0);
        if(!SPFA(N+1,N+1))printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

 

       

    原文作者:kuangbin
    原文地址: https://www.cnblogs.com/kuangbin/p/3140385.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞