POJ 3660 Cow Contest(传递闭包floyed算法)

Cow Contest

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5989 Accepted: 3234

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

Source

USACO 2008 January Silver     题目给出了m对的相对关系,求有多少个排名是确定的。 使用floyed求一下传递闭包。如果这个点和其余的关系都是确定的,那么这个点的排名就是确定的。

//============================================================================
// Name        : POJ.cpp
// Author      : 
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================
/*
 * floyed算法,传递闭包。如果一个点和其余点的关系都是确定的,则这个的排名是确定的
 */
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
using namespace std;
const int MAXN=110;
int win[MAXN][MAXN];
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)==2)
    {
        memset(win,0,sizeof(win));
        int u,v;
        while(m--)
        {
            scanf("%d%d",&u,&v);
            win[u][v]=1;
        }
        for(int k=1;k<=n;k++)
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    if(win[i][k]&&win[k][j])
                        win[i][j]=1;
        int ans=0;
        int j;
        for(int i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(i==j)continue;
                if(win[i][j]==0&&win[j][i]==0)break;//关系不确定
            }
            if(j>n)ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

     

    原文作者:kuangbin
    原文地址: https://www.cnblogs.com/kuangbin/p/3140837.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞