HDU 4352 XHXJ's LIS(数位DP)

XHXJ’s LIS

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 376    Accepted Submission(s): 163

Problem Description #define xhxj (Xin Hang senior sister(学姐)) 

If you do not know xhxj, then carefully reading the entire description is very important.

As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu.

Like many god cattles, xhxj has a legendary life: 

2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year’s summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world’s final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world’s final(there is only one team for every university to send to the world’s final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final.

As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo’s, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, “this problem has a very good properties”,she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type.

Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: “Why do not you go to improve your programming skill”. When she receives sincere compliments from others, she would say modestly: “Please don’t flatter at me.(Please don’t black).”As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls.

Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k.. It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in [L,R] in O(1)time.

For the first one to solve this problem,xhxj will upgrade 20 favorability rate。  

 

Input First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.(

0<L<=R<2
63-1 and 1<=K<=10).  

 

Output For each query, print “Case #t: ans” in a line, in which t is the number of the test case starting from 1 and ans is the answer.  

 

Sample Input 1 123 321 2  

 

Sample Output Case #1: 139  

 

Author peterae86@UESTC03  

 

Source
2012 Multi-University Training Contest 6  

 

Recommend zhuyuanchen520       比较难懂的意思。 具体看代码注释。

/*
 * HDU 4352 XHXJ's LIS
 * 问L到R,各位数字组成的严格上升子序列的长度为K的个数。
 * 0<L<=R<263-1 and 1<=K<=10
 * 注意这里最长上升子序列的定义,和LIS是一样的,不要求是连续的
 * 所以用十位二进制表示0~9出现的情况,和O(nlogn)求LIS一样的方法进行更新
 * 
 */

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
long long dp[25][1<<10][11];
/*
 * dp[i][j][k]:i为当前进行到的数位,j状态压缩,为10个数字出现过的,其中1的个数就是最长上升子序列,k要求的上升子序列的长度
 */
int K;
int getnews(int x,int s)//更新新的状态
{
    for(int i=x;i<10;i++)
        if(s&(1<<i))return (s^(1<<i))|(1<<x);
    return s|(1<<x);
}
int getnum(int s)//得到状态s中1的个数
{
    int ret=0;
    while(s)
    {
        if(s&1)ret++;
        s>>=1;
    }
    return ret;
}
int bit[25];
long long dfs(int pos,int s,bool e,bool z)//e是是不是上界标记,z是是不是前面的为0标记
{
    if(pos==-1)return getnum(s)==K;
    if(!e &&dp[pos][s][K]!=-1)return dp[pos][s][K];
    long long ans=0;
    int end=e?bit[pos]:9;
    for(int i=0;i<=end;i++)
        ans+=dfs(pos-1,(z&&i==0)?0:getnews(i,s),e&&i==end,z&&(i==0));
    if(!e)dp[pos][s][K]=ans;
    return ans;
}
long long calc(long long n)
{
    int len=0;
    while(n)
    {
        bit[len++]=n%10;
        n/=10;
    }
    return dfs(len-1,0,1,1);
}
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int T;
    long long l,r;
    memset(dp,-1,sizeof(dp));
    scanf("%d",&T);
    int iCase=0;
    while(T--)
    {
        iCase++;
        scanf("%I64d%I64d%d",&l,&r,&K);
        printf("Case #%d: ",iCase);
        printf("%I64d\n",calc(r)-calc(l-1));
    }
    return 0;
}

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/archive/2013/05/01/3052657.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞