HDU 2425 DNA repair (AC自动机+DP)

DNA repair

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 940    Accepted Submission(s): 500

Problem Description Biologists finally invent techniques of repairing DNA that contains segments causing kinds of inherited diseases. For the sake of simplicity, a DNA is represented as a string containing characters ‘A’, ‘G’ , ‘C’ and ‘T’. The repairing techniques are simply to change some characters to eliminate all segments causing diseases. For example, we can repair a DNA “AAGCAG” to “AGGCAC” to eliminate the initial causing disease segments “AAG”, “AGC” and “CAG” by changing two characters. Note that the repaired DNA can still contain only characters ‘A’, ‘G’, ‘C’ and ‘T’.

You are to help the biologists to repair a DNA by changing least number of characters.  

 

Input The input consists of multiple test cases. Each test case starts with a line containing one integers N (1 ≤ N ≤ 50), which is the number of DNA segments causing inherited diseases.

The following N lines gives N non-empty strings of length not greater than 20 containing only characters in “AGCT”, which are the DNA segments causing inherited disease.

The last line of the test case is a non-empty string of length not greater than 1000 containing only characters in “AGCT”, which is the DNA to be repaired.

The last test case is followed by a line containing one zeros.  

 

Output For each test case, print a line containing the test case number( beginning with 1) followed by the

number of characters which need to be changed. If it’s impossible to repair the given DNA, print -1.  

 

Sample Input 2 AAA AAG AAAG 2 A TG TGAATG 4 A G C T AGT 0  

 

Sample Output Case 1: 1 Case 2: 4 Case 3: -1  

 

Source
2008 Asia Hefei Regional Contest Online by USTC  

 

Recommend teddy

 

 

AC自动机+DP;

 

就是记录不包含坏串的位置。

然后进行状态的转移

 

//============================================================================
// Name        : HDU.cpp
// Author      : 
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <queue>
using namespace std;
const int INF = 0x3f3f3f3f;
struct Trie
{
    int next[1010][4],fail[1010];
    bool end[1010];
    int root,L;
    int newnode()
    {
        for(int i = 0;i < 4;i++)
            next[L][i] = -1;
        end[L++] = false;
        return L-1;
    }
    void init()
    {
        L = 0;
        root = newnode();
    }
    int getch(char ch)
    {
        if(ch == 'A')return 0;
        else if(ch == 'C')return 1;
        else if(ch == 'G')return 2;
        else if(ch == 'T')return 3;
    }
    void insert(char buf[])
    {
        int len = strlen(buf);
        int now = root;
        for(int i = 0;i < len;i++)
        {
            if(next[now][getch(buf[i])] == -1)
                next[now][getch(buf[i])] = newnode();
            now = next[now][getch(buf[i])];
        }
        end[now] = true;
    }
    void build()
    {
        queue<int>Q;
        fail[root] = root;
        for(int i = 0;i < 4;i++)
            if(next[root][i] == -1)
                next[root][i] = root;
            else
            {
                fail[next[root][i]] = root;
                Q.push(next[root][i]);
            }
        while(!Q.empty())
        {
            int now = Q.front();
            Q.pop();
            if(end[fail[now]])end[now] = true;
            for(int i = 0;i < 4;i++)
                if(next[now][i] == -1)
                    next[now][i] = next[fail[now]][i];
                else
                {
                    fail[next[now][i]] = next[fail[now]][i];
                    Q.push(next[now][i]);
                }
        }
    }
    int dp[1010][1010];
    int solve(char buf[])
    {
        int len = strlen(buf);
        for(int i = 0;i <= len;i++)
            for(int j = 0;j < L;j++)
                dp[i][j] = INF;
        dp[0][root] = 0;
        for(int i = 0;i < len;i++)
            for(int j = 0;j < L;j++)
                if(dp[i][j] < INF)
                {
                    for(int k = 0;k < 4;k++)
                    {
                        int news = next[j][k];
                        if(end[news])continue;
                        int tmp;
                        if( k == getch(buf[i]))tmp = dp[i][j];
                        else tmp = dp[i][j] + 1;
                        dp[i+1][news] = min(dp[i+1][news],tmp);
                    }
                }
        int ans = INF;
        for(int j = 0;j < L;j++)
            ans = min(ans,dp[len][j]);
        if(ans == INF)ans = -1;
        return ans;
    }

};
char buf[1010];
Trie ac;
int main()
{
    int n;
    int iCase = 0;
    while ( scanf("%d",&n) == 1 && n)
    {
        iCase++;
        ac.init();
        while(n--)
        {
            scanf("%s",buf);
            ac.insert(buf);
        }
        ac.build();
        scanf("%s",buf);
        printf("Case %d: %d\n",iCase,ac.solve(buf));
    }
    return 0;
}

 

 

 

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/p/3162957.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞