HDU 3072 Intelligence System (强连通分量)

Intelligence System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 982    Accepted Submission(s): 440

Problem Description After a day, ALPCs finally complete their ultimate intelligence system, the purpose of it is of course for ACM … … 

Now, kzc_tc, the head of the Intelligence Department (his code is once 48, but now 0), is sudden obtaining important information from one Intelligence personnel. That relates to the strategic direction and future development of the situation of ALPC. So it need for emergency notification to all Intelligence personnel, he decides to use the intelligence system (kzc_tc inform one, and the one inform other one or more, and so on. Finally the information is known to all).

We know this is a dangerous work. Each transmission of the information can only be made through a fixed approach, from a fixed person to another fixed, and cannot be exchanged, but between two persons may have more than one way for transferring. Each act of the transmission cost Ci (1 <= Ci <= 100000), the total cost of the transmission if inform some ones in our ALPC intelligence agency is their costs sum. 

Something good, if two people can inform each other, directly or indirectly through someone else, then they belong to the same branch (kzc_tc is in one branch, too!). This case, it’s very easy to inform each other, so that the cost between persons in the same branch will be ignored. The number of branch in intelligence agency is no more than one hundred.

As a result of the current tensions of ALPC’s funds, kzc_tc now has all relationships in his Intelligence system, and he want to write a program to achieve the minimum cost to ensure that everyone knows this intelligence.

It’s really annoying!  

 

Input There are several test cases. 

In each case, the first line is an Integer N (0< N <= 50000), the number of the intelligence personnel including kzc_tc. Their code is numbered from 0 to N-1. And then M (0<= M <= 100000), the number of the transmission approach.

The next M lines, each line contains three integers, X, Y and C means person X transfer information to person Y cost C.   

 

Output The minimum total cost for inform everyone.

Believe kzc_tc’s working! There always is a way for him to communicate with all other intelligence personnel.  

 

Sample Input 3 3 0 1 100 1 2 50 0 2 100 3 3 0 1 100 1 2 50 2 1 100 2 2 0 1 50 0 1 100  

 

Sample Output 150 100 50  

 

Source
2009 Multi-University Training Contest 17 – Host by NUDT  

 

Recommend lcy           题意很纠结。。。   其实就是一个连通分量的权值不算。问从一个点出发到达其余所有点需要的最小权值和。   强连通分量缩点得到DAG图     然后每个点取入边的最小值,然后求和就可以了    

//============================================================================
// Name        : HDU.cpp
// Author      : 
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

/*
 * Tarjan算法
 * 复杂度O(N+M)
 */
const int MAXN = 50010;
const int MAXM = 100010;
struct Edge
{
    int to,next;
}edge[MAXM];
int head[MAXN],tot;
int Low[MAXN],DFN[MAXN],Stack[MAXN],Belong[MAXN];
int Index,top;
int scc;
bool Instack[MAXN];
void addedge(int u,int v)
{
    edge[tot].to = v;edge[tot].next = head[u];head[u] = tot++;
}
void Tarjan(int u)
{
    int v;
    DFN[u] = Low[u] = ++Index;
    Stack[top++] = u;
    Instack[u] = true;
    for(int i = head[u];i != -1;i = edge[i].next)
    {
        v = edge[i].to;
        if(!DFN[v])
        {
            Tarjan(v);
            if( Low[u] > Low[v] )Low[u] = Low[v];
        }
        else if(Instack[v] && Low[u] > DFN[v])Low[u] = DFN[v];
    }
    if(Low[u] == DFN[u])
    {
        scc++;
        do
        {
            v = Stack[--top];
            Instack[v] = false;
            Belong[v] = scc;
        }
        while( v != u );
    }
}
void solve(int n)
{
    memset(DFN,0,sizeof(DFN));
    memset(Instack,false,sizeof(Instack));
    Index = scc = top = 0;
    for(int i = 1;i <= n;i++)
        if(!DFN[i])
            Tarjan(i);
}
void init()
{
    tot = 0;
    memset(head,-1,sizeof(head));
}
struct Node
{
    int u,v,c;
}node[MAXM];
int a[MAXN];
const int INF = 0x3f3f3f3f;
int main()
{
    int n,m;
    int u,v,c;
    while(scanf("%d%d",&n,&m) == 2)
    {
        init();
        for(int i = 0;i < m;i++)
        {
            scanf("%d%d%d",&u,&v,&c);
            u++;
            v++;
            node[i].u= u;
            node[i].v = v;
            node[i].c = c;
            addedge(u,v);
        }
        solve(n);
        for(int i = 1;i <= scc;i++)
            a[i] = INF;
        for(int i = 0;i < m;i++)
        {
            int t1 = Belong[node[i].u];
            int t2 = Belong[node[i].v];
            if(t1 != t2)
            {
                a[t2] = min(a[t2],node[i].c);
            }
        }
        int ans = 0;
        for(int i = 1;i <= scc;i++)
            if(a[i] != INF)
                ans+=a[i];
        printf("%d\n",ans);
    }
    return 0;
}

 

   

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/p/3175641.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞