HDU 4417 Super Mario(划分树)

Super Mario

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1437    Accepted Submission(s): 690

Problem Description Mario is world-famous plumber. His “burly” figure and amazing jumping ability reminded in our memory. Now the poor princess is in trouble again and Mario needs to save his lover. We regard the road to the boss’s castle as a line (the length is n), on every integer point i there is a brick on height hi. Now the question is how many bricks in [L, R] Mario can hit if the maximal height he can jump is H.  

 

Input The first line follows an integer T, the number of test data.

For each test data:

The first line contains two integers n, m (1 <= n <=10^5, 1 <= m <= 10^5), n is the length of the road, m is the number of queries.

Next line contains n integers, the height of each brick, the range is [0, 1000000000].

Next m lines, each line contains three integers L, R,H.( 0 <= L <= R < n 0 <= H <= 1000000000.)  

 

Output For each case, output “Case X: ” (X is the case number starting from 1) followed by m lines, each line contains an integer. The ith integer is the number of bricks Mario can hit for the ith query.  

 

Sample Input 1 10 10 0 5 2 7 5 4 3 8 7 7 2 8 6 3 5 0 1 3 1 1 9 4 0 1 0 3 5 5 5 5 1 4 6 3 1 5 7 5 7 3  

 

Sample Output Case 1: 4 0 0 3 1 2 0 1 5 1  

 

Source
2012 ACM/ICPC Asia Regional Hangzhou Online  

 

Recommend liuyiding  

 

 

 

这题就是查询一个区间内小于等于一个数的数的个数。

用树状数组离线搞过。

 

修改下划分树模板也可以搞定

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <string.h>
using namespace std;
const int MAXN = 100010;
int tree[20][MAXN];
int sorted[MAXN];
int toleft[20][MAXN];

void build(int l,int r,int dep)
{
    if(l == r)return;
    int mid = (l+r)>>1;
    int same = mid-l+1;
    for(int i = l;i <= r;i++)
        if(tree[dep][i] < sorted[mid])
            same--;
    int lpos = l;
    int rpos = mid+1;
    for(int i = l;i <= r;i++)
    {
        if(tree[dep][i] < sorted[mid])
            tree[dep+1][lpos++] = tree[dep][i];
        else if(tree[dep][i] == sorted[mid] && same > 0)
        {
            tree[dep+1][lpos++] = tree[dep][i];
            same--;
        }
        else
            tree[dep+1][rpos++] = tree[dep][i];
        toleft[dep][i] = toleft[dep][l-1] + lpos - l;
    }
    build(l,mid,dep+1);
    build(mid+1,r,dep+1);
}
//查询区间[l,r]上比k小于等于的数的个数
int query(int L,int R,int l,int r,int dep,int k)
{
    //printf("%d %d %d %d %d %d\n",L,R,l,r,dep,k);
    if(l == r)
    {
        if(tree[dep][l] <= k)return 1;
        else return 0;
    }
    int mid = (L+R)>>1;
    int cnt = toleft[dep][r] - toleft[dep][l-1];
    if(sorted[mid] <= k)
    {
        int newr = r + toleft[dep][R] - toleft[dep][r];
        int newl = newr - (r-l+1-cnt) + 1;
        return cnt + query(mid+1,R,newl,newr,dep+1,k);
    }
    else
    {
        int newl = L + toleft[dep][l-1] - toleft[dep][L-1];
        int newr = newl + cnt -1;
        if(newr >= newl)return query(L,mid,newl,newr,dep+1,k);
        else return 0;
    }
}
int main()
{
    int T;
    int iCase = 0;
    scanf("%d",&T);
    int n;
    while(T--)
    {
        iCase ++;
        int m;
        scanf("%d%d",&n,&m);
        memset(tree,0,sizeof(tree));
        memset(toleft,0,sizeof(toleft));
        for(int i = 1;i <= n;i++)
        {
            scanf("%d",&tree[0][i]);
            sorted[i] = tree[0][i];
        }
        sort(sorted+1,sorted+n+1);
        build(1,n,0);
        int L,R,H;
        printf("Case %d:\n",iCase);
        while(m--)
        {
            scanf("%d%d%d",&L,&R,&H);
            L++;R++;
            printf("%d\n",query(1,n,L,R,0,H));
        }
    }
    return 0;
}

 

 

    原文作者:算法小白
    原文地址: https://www.cnblogs.com/kuangbin/p/3224437.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞