HDU 3535 AreYouBusy 经典混合背包

AreYouBusy

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1

Problem Description Happy New Term! As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad. What’s more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as “jobs”. A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss’s advice)?   Input There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.   Output One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .   Sample Input 3 3 2 1 2 5 3 8 2 0 1 0 2 1 3 2 4 3 2 1 1 1

3 4 2 1 2 5 3 8 2 0 1 1 2 8 3 2 4 4 2 1 1 1

1 1 1 0 2 1

5 3 2 0 1 0 2 1 2 0 2 2 1 1 2 0 3 2 2 1 2 1 1 5 2 8 3 2 3 8 4 9 5 10   Sample Output 5 13 -1 -1   Author hphp   Source 2010 ACM-ICPC Multi-University Training Contest(10)——Host by HEU  

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 1<<29
int n, m, sum, g;
int w[101],p[101];
int dp[101],tmp[101];
int main()
{
    int i, j, x;
    while(~scanf("%d%d",&n,&sum))//输入总共有多少种,以及这个人的背包体积是多少
    {
        memset(dp,0,sizeof(dp));//初始化
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&m,&g);//输入物品的种类,以及物品的个数
            for(x=1;x<=m;x++)
                scanf("%d%d",&w[x],&p[x]);//输入这种物品的体积以及价值
            if(g==0)//至少选择一个的
            {
                for(j=0;j<=sum;j++)
                {
                    tmp[j]=dp[j];
                    dp[j]=-INF;
                }//对每一个都进行初始化
                for(x=1;x<=m;x++)
                    for(j=sum;j>=w[x];j--)
                        dp[j]=max(dp[j],max(dp[j-w[x]]+p[x],tmp[j-w[x]]+p[x]));
            }
            else if(g==1)
            {
                for(j=0;j<=sum;j++) //当前组初始化
                    tmp[j]=dp[j];
                for(x=1;x<=m;x++)
                    for(j=sum;j>=w[x];j--)
                            dp[j]=max(dp[j],tmp[j-w[x]]+p[x]);//拿一个临时数组确保每个状态最多选择了一个
            }
            else if(g==2)
            {
                for(j=0;j<=sum;j++) //当前组初始化
                    tmp[j]=dp[j];
                for(x=1;x<=m;x++)
                    for(j=sum;j>=w[x];j--)
                        dp[j]=max(dp[j],dp[j-w[x]]+p[x]);
            }//普通背包

        }
        dp[sum]=max(dp[sum],-1); //没有完成任务的值都为负的,做输出调整,输出-1
        printf("%d\n",dp[sum]);
    }
    return 0;
}

 

    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/4139171.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞